summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-11-29 08:53:46 +0100
committerRemi Collet <remi@remirepo.net>2019-11-29 08:53:46 +0100
commitead02f29a49bd8586b3e134812c177eb44d65bec (patch)
tree407c988ae96678f2b883caa3a1fd193848d953ce
parentedc780d93257c213b834ef773d8d4a3c0d7fdd9b (diff)
- update to 6.1.0HEADmaster
- raise dependency on phpspec/prophecy 1.9 - use phpunit7
-rw-r--r--composer.json20
-rw-r--r--php-phpspec.spec42
2 files changed, 33 insertions, 29 deletions
diff --git a/composer.json b/composer.json
index f786366..e665867 100644
--- a/composer.json
+++ b/composer.json
@@ -22,23 +22,23 @@
],
"require": {
- "php": "^7.2, <7.4",
- "phpspec/prophecy": "^1.7",
+ "php": "^7.2, <7.5",
+ "phpspec/prophecy": "^1.9",
"phpspec/php-diff": "^1.0.0",
"sebastian/exporter": "^1.0 || ^2.0 || ^3.0",
- "symfony/console": "^3.4 || ^4.0",
- "symfony/event-dispatcher": "^3.4 || ^4.0",
- "symfony/process": "^3.4 || ^4.0",
- "symfony/finder": "^3.4 || ^4.0",
- "symfony/yaml": "^3.4 || ^4.0",
+ "symfony/console": "^3.4 || ^4.0 || ^5.0",
+ "symfony/event-dispatcher": "^3.4 || ^4.0 || ^5.0",
+ "symfony/process": "^3.4 || ^4.0 || ^5.0",
+ "symfony/finder": "^3.4 || ^4.0 || ^5.0",
+ "symfony/yaml": "^3.4 || ^4.0 || ^5.0",
"doctrine/instantiator": "^1.0.5",
"ext-tokenizer": "*"
},
"require-dev": {
"behat/behat": "^3.3",
- "symfony/filesystem": "^3.4 || ^4.0",
- "phpunit/phpunit": "^5.7 || ^6.0"
+ "symfony/filesystem": "^3.4 || ^4.0 || ^5.0",
+ "phpunit/phpunit": "^7.0"
},
"suggest": {
@@ -65,7 +65,7 @@
"extra": {
"branch-alias": {
- "dev-master": "6.0.x-dev"
+ "dev-master": "6.1.x-dev"
}
}
diff --git a/php-phpspec.spec b/php-phpspec.spec
index fcaab4c..1aaabfa 100644
--- a/php-phpspec.spec
+++ b/php-phpspec.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit d78e90427386063729afe989f9038da0c3212dff
+%global gh_commit 8004e609e4d365555a85617c36d30127e3233517
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project phpspec
@@ -24,7 +24,7 @@
%global symfony_max 5
Name: php-phpspec
-Version: 6.0.0
+Version: 6.1.0
Release: 1%{?dist}
Summary: Specification-oriented BDD framework for PHP
@@ -41,13 +41,13 @@ BuildArch: noarch
BuildRequires: php(language) >= 7.2
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(phpspec/prophecy) >= 1.7 with php-composer(phpspec/prophecy) < 2)
+BuildRequires: (php-composer(phpspec/prophecy) >= 1.9 with php-composer(phpspec/prophecy) < 2)
BuildRequires: (php-composer(phpspec/php-diff) >= 1.0.0 with php-composer(phpspec/php-diff) < 2)
BuildRequires: (php-composer(sebastian/exporter) >= 3 with php-composer(sebastian/exporter) < 4)
BuildRequires: (php-composer(doctrine/instantiator) >= 1.0.5 with php-composer(doctrine/instantiator) < 2)
# remirepo:6
%else
-BuildRequires: php-phpspec-prophecy >= 1.7
+BuildRequires: php-phpspec-prophecy >= 1.9
BuildRequires: php-phpspec-php-diff >= 1.0.0
BuildRequires: php-sebastian-exporter3 >= 3
BuildRequires: php-doctrine-instantiator >= 1.0.5
@@ -59,36 +59,36 @@ BuildRequires: php-symfony4-process >= %{symfony_min}
BuildRequires: php-symfony4-yaml >= %{symfony_min}
# From composer.json, require-dev
# "behat/behat": "^3.3",
-# "symfony/filesystem": "^3.4 || ^4.0",
-# "phpunit/phpunit": "^5.7 || ^6.0",
+# "symfony/filesystem": "^3.4 || ^4.0 || ^5.0",
+# "phpunit/phpunit": "^7.0",
BuildRequires: php-symfony4-filesystem >= %{symfony_min}
-BuildRequires: phpunit6
+BuildRequires: phpunit7
# Autoloader
BuildRequires: php-composer(fedora/autoloader) >= 1
# From composer.json, require
-# "php": "^7.2, <7.4",
-# "phpspec/prophecy": "^1.7",
+# "php": "^7.2, <7.5",
+# "phpspec/prophecy": "^1.9",
# "phpspec/php-diff": "^1.0.0",
# "sebastian/exporter": "^1.0 || ^2.0 || ^3.0",
-# "symfony/console": "^3.2 || ^4.0",
-# "symfony/event-dispatcher": "^3.2 || ^4.0",
-# "symfony/process": "^3.2 || ^4.0",
-# "symfony/finder": "^3.2 || ^4.0",
-# "symfony/yaml": "^3.2 || ^4.0",
+# "symfony/console": "^3.2 || ^4.0 || ^5.0",
+# "symfony/event-dispatcher": "^3.2 || ^4.0 || ^5.0",
+# "symfony/process": "^3.2 || ^4.0 || ^5.0",
+# "symfony/finder": "^3.2 || ^4.0 || ^5.0",
+# "symfony/yaml": "^3.2 || ^4.0 || ^5.0",
# "doctrine/instantiator": "^1.0.5"
# "ext-tokenizer": "*"
Requires: php(language) >= 7.2
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(phpspec/prophecy) >= 1.7 with php-composer(phpspec/prophecy) < 2)
+Requires: (php-composer(phpspec/prophecy) >= 1.9 with php-composer(phpspec/prophecy) < 2)
Requires: (php-composer(phpspec/php-diff) >= 1.0.0 with php-composer(phpspec/php-diff) < 2)
Requires: (php-composer(sebastian/exporter) >= 3 with php-composer(sebastian/exporter) < 4)
Requires: (php-composer(doctrine/instantiator) >= 1.0.5 with php-composer(doctrine/instantiator) < 2)
# remirepo:6
%else
-Requires: php-phpspec-prophecy >= 1.7
+Requires: php-phpspec-prophecy >= 1.9
Requires: php-phpspec-php-diff >= 1.0.0
Requires: php-sebastian-exporter3 >= 3
Requires: php-doctrine-instantiator >= 1.0.5
@@ -159,14 +159,13 @@ rm spec/PhpSpec/NamespaceProvider/ComposerPsrNamespaceProviderSpec.php
sed -e 's/it_compare_array_of_objects_to_and_displays_its_properties/skipit1/' \
-i spec/PhpSpec/Formatter/Presenter/Differ/ArrayEngineSpec.php
-# TODO 7.4
-for cmd in php php71 php72 php73; do
+for cmd in php php71 php72 php73 php74; do
if which $cmd; then
$cmd -d memory_limit=1G -d include_path=.:%{buildroot}%{_datadir}/php \
bin/phpspec \
run --format pretty --verbose --no-ansi
- $cmd %{_bindir}/phpunit6 \
+ $cmd %{_bindir}/phpunit7 \
--verbose \
--bootstrap %{buildroot}%{_datadir}/php/PhpSpec/autoload.php
fi
@@ -184,6 +183,11 @@ done
%changelog
+* Fri Nov 29 2019 Remi Collet <remi@remirepo.net> - 6.1.0-1
+- update to 6.1.0
+- raise dependency on phpspec/prophecy 1.9
+- use phpunit7
+
* Wed Oct 2 2019 Remi Collet <remi@remirepo.net> - 6.0.0-1
- update to 6.0.0
- raise dependency to PHP 7.2