summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-02-01 12:26:12 +0100
committerRemi Collet <remi@remirepo.net>2019-02-01 12:26:12 +0100
commitd8c5ad709d4c0913ce2b50264027e554fca95433 (patch)
tree6bff9e8b083ecd7698b7c46849c94c9954aa0fb9
parent59374aede7b86858f4a04c93d15949b5d3d32d2e (diff)
use Symfony component autoloaders
-rw-r--r--php-phpspec.spec8
-rw-r--r--phpspec-autoload.php6
2 files changed, 10 insertions, 4 deletions
diff --git a/php-phpspec.spec b/php-phpspec.spec
index ef81e9a..21e90ec 100644
--- a/php-phpspec.spec
+++ b/php-phpspec.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-phpspec
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -25,10 +25,9 @@
Name: php-phpspec
Version: 5.1.0
-Release: 2%{?dist}
+Release: 3%{?dist}
Summary: Specification-oriented BDD framework for PHP
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}%{?prever}-%{gh_short}.tar.gz
@@ -183,6 +182,9 @@ done
%changelog
+* Fri Feb 1 2019 Remi Collet <remi@remirepo.net> - 5.1.0-3
+- use Symfony component autoloaders
+
* Tue Nov 20 2018 Remi Collet <remi@remirepo.net> - 5.1.0-2
- ignore failed test on 32-bit arch FTBFS #1651396
reported as https://github.com/phpspec/phpspec/issues/1234
diff --git a/phpspec-autoload.php b/phpspec-autoload.php
index 066d8d7..b7858c6 100644
--- a/phpspec-autoload.php
+++ b/phpspec-autoload.php
@@ -4,7 +4,6 @@
require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('PhpSpec\\', __DIR__);
-\Fedora\Autoloader\Autoload::addPsr4('Symfony\\Component\\', '/usr/share/php/@SYMFONY@/Component');
/* spec tree in current dir, when exists */
if (is_dir(getcwd().'/spec')) {
@@ -13,6 +12,11 @@ if (is_dir(getcwd().'/spec')) {
// Dependencies (Rely on include_path as in PHPUnit dependencies + circular dependencies)
\Fedora\Autoloader\Dependencies::required([
+ '/usr/share/php/@SYMFONY@/Component/Console/autoload.php',
+ '/usr/share/php/@SYMFONY@/Component/EventDispatcher/autoload.php',
+ '/usr/share/php/@SYMFONY@/Component/Finder/autoload.php',
+ '/usr/share/php/@SYMFONY@/Component/Process/autoload.php',
+ '/usr/share/php/@SYMFONY@/Component/Yaml/autoload.php',
'phpspec/php-diff/autoload.php',
'Prophecy/autoload.php',
'Doctrine/Instantiator/autoload.php',