summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-10-19 06:11:34 +0200
committerRemi Collet <remi@remirepo.net>2017-10-19 06:11:34 +0200
commitad89049fd795f7f4430cf44834bd9c6829095161 (patch)
treee82e6d5dfed64849d363bfadbf1c1f93b2742df2
parent694307d2b0930b52ae6fad525d54f370d4a60b5f (diff)
v4.1.0
-rw-r--r--composer.json2
-rw-r--r--php-phpspec.spec11
2 files changed, 7 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 480ef28..4022a60 100644
--- a/composer.json
+++ b/composer.json
@@ -22,7 +22,7 @@
],
"require": {
- "php": "^7.0,<7.2",
+ "php": "^7.0,<7.3",
"phpspec/prophecy": "^1.5",
"phpspec/php-diff": "^1.0.0",
"sebastian/exporter": "^1.0 || ^2.0 || ^3.0",
diff --git a/php-phpspec.spec b/php-phpspec.spec
index 8f2dfd5..97f7335 100644
--- a/php-phpspec.spec
+++ b/php-phpspec.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 6c565f96cac52682684b0c02a180722ceead2c6c
+%global gh_commit e5cd03ab0b2de7a8ce411c9ff18cd17c3a2a7ed2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project phpspec
@@ -19,7 +19,7 @@
%global symfony_max 4
Name: php-phpspec
-Version: 4.0.3
+Version: 4.1.0
Release: 1%{?dist}
Summary: Specification-oriented BDD framework for PHP
@@ -64,7 +64,7 @@ BuildRequires: phpunit6
BuildRequires: php-composer(fedora/autoloader) >= 1
# From composer.json, require
-# "php": "^7.0,<7.2",
+# "php": "^7.0,<7.3",
# "phpspec/prophecy": "^1.5",
# "phpspec/php-diff": "^1.0.0",
# "sebastian/exporter": "^1.0 || ^2.0 || ^3.0",
@@ -151,8 +151,6 @@ rm spec/PhpSpec/Message/CurrentExampleTrackerSpec.php
# Ignore this test which rely on composer installation
rm spec/PhpSpec/NamespaceProvider/ComposerPsrNamespaceProviderSpec.php
-# PHP 7.2: https://github.com/phpspec/phpspec/issues/1094
-
for cmd in php php70 php71 php72; do
if which $cmd; then
$cmd -d memory_limit=1G -d include_path=.:%{buildroot}%{_datadir}/php \
@@ -176,6 +174,9 @@ done
%changelog
+* Thu Oct 19 2017 Remi Collet <remi@remirepo.net> - 4.1.0-1
+- Update to 4.1.0
+
* Sun Aug 27 2017 Remi Collet <remi@remirepo.net> - 4.0.3-1
- Update to 4.0.3
- raise memory_limit for test suite