summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-12 10:21:47 +0200
committerRemi Collet <remi@remirepo.net>2017-05-12 10:21:47 +0200
commitaafdd610c6c68f2a30924e4ac54e42269825dd65 (patch)
tree873c343457f1359efcc9fc100d152d2915fc7921
parent74fcac38d0fa7ce318465934f208e37e42511541 (diff)
v3.4.0
-rw-r--r--php-phpspec.spec62
1 files changed, 22 insertions, 40 deletions
diff --git a/php-phpspec.spec b/php-phpspec.spec
index 52ee67d..5b22735 100644
--- a/php-phpspec.spec
+++ b/php-phpspec.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 1c77d11878c4bd475bc66f0eaa2686df0fcfa30f
+%global gh_commit 2e969c7d8c6437490b7aa0ab51a3302d15bb7211
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project phpspec
@@ -25,8 +25,8 @@
%endif
Name: php-phpspec
-Version: 3.3.0
-Release: 3%{?dist}
+Version: 3.4.0
+Release: 1%{?dist}
Summary: Specification-oriented BDD framework for PHP
Group: Development/Libraries
@@ -162,44 +162,23 @@ export LANG=en_GB.utf8
# Ignore this test which use bossa/phpspec2-expect
rm spec/PhpSpec/Message/CurrentExampleTrackerSpec.php
+# Ignore this test which rely on composer installation
+rm spec/PhpSpec/NamespaceProvider/ComposerPsrNamespaceProviderSpec.php
-# remirepo:26
-run=0
-if which php56; then
- php56 \
- -d include_path=.:%{buildroot}%{_datadir}/php \
- bin/phpspec \
- run --format pretty --verbose --no-ansi
-
- php56 %{_bindir}/phpunit \
- --verbose \
- --bootstrap %{buildroot}%{_datadir}/php/PhpSpec/autoload.php
-
- run=1
-fi
-if which php71; then
- php71 \
- -d include_path=.:%{buildroot}%{_datadir}/php \
- bin/phpspec \
- run --format pretty --verbose --no-ansi
-
- php71 %{_bindir}/phpunit6 \
- --verbose \
- --bootstrap %{buildroot}%{_datadir}/php/PhpSpec/autoload.php
-
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/php \
- -d include_path=.:%{buildroot}%{_datadir}/php \
- bin/phpspec \
- run --format pretty --verbose --no-ansi
-
-%{phpunit} \
- --verbose \
- --bootstrap %{buildroot}%{_datadir}/php/PhpSpec/autoload.php
-# remirepo:2
-fi
+# PHP 7.2: https://github.com/phpspec/phpspec/issues/1094
+
+for cmd in "php %{phpunit}" "php56 %{_bindir}/phpunit" "php70 %{_bindir}/phpunit6" "php71 %{_bindir}/phpunit6"; do
+ if which $cmd; then
+ set $cmd
+ $1 -d include_path=.:%{buildroot}%{_datadir}/php \
+ bin/phpspec \
+ run --format pretty --verbose --no-ansi
+
+ $1 $2 \
+ --verbose \
+ --bootstrap %{buildroot}%{_datadir}/php/PhpSpec/autoload.php
+ fi
+done
%files
@@ -212,6 +191,9 @@ fi
%changelog
+* Fri May 12 2017 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- Update to 3.4.0
+
* Thu May 11 2017 Remi Collet <remi@remirepo.net> - 3.3.0-3
- only allow a single Symfony version