summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-10-29 10:16:52 +0100
committerRemi Collet <remi@remirepo.net>2018-10-29 10:16:52 +0100
commit9742411d2c7cb2a7513b968775960eb0f7f67e25 (patch)
treeb4906e7ebfc264ceb2d5dfcc94deff926e67bbcb
parent25a289902b37d8a1eb33240c2850331a12c6d11c (diff)
v5.1.0
-rw-r--r--composer.json4
-rw-r--r--php-phpspec.spec12
2 files changed, 8 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index fa536f6..af3e08b 100644
--- a/composer.json
+++ b/composer.json
@@ -22,7 +22,7 @@
],
"require": {
- "php": "^7.1, <7.3",
+ "php": "^7.1, <7.4",
"phpspec/prophecy": "^1.7",
"phpspec/php-diff": "^1.0.0",
"sebastian/exporter": "^1.0 || ^2.0 || ^3.0",
@@ -61,7 +61,7 @@
"extra": {
"branch-alias": {
- "dev-master": "5.0.x-dev"
+ "dev-master": "5.1.x-dev"
}
}
}
diff --git a/php-phpspec.spec b/php-phpspec.spec
index 81b657e..2318bd7 100644
--- a/php-phpspec.spec
+++ b/php-phpspec.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 6c0351a46582be027f3e504c93789427cdd4bcda
+%global gh_commit 4badea737c34a6c8e2921fca0f6a1cbe4f724f2f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project phpspec
@@ -24,7 +24,7 @@
%global symfony_max 5
Name: php-phpspec
-Version: 5.0.3
+Version: 5.1.0
Release: 1%{?dist}
Summary: Specification-oriented BDD framework for PHP
@@ -37,8 +37,6 @@ Source1: %{gh_project}-autoload.php
# Use our autoloader
Patch0: %{gh_project}-4-rpm.patch
-# From https://github.com/phpspec/phpspec/pull/1212
-Patch1: 1212.patch
BuildArch: noarch
BuildRequires: php(language) >= 7.1
@@ -70,7 +68,7 @@ BuildRequires: phpunit6
BuildRequires: php-composer(fedora/autoloader) >= 1
# From composer.json, require
-# "php": "^7.0,<7.3",
+# "php": "^7.0,<7.4",
# "phpspec/prophecy": "^1.7",
# "phpspec/php-diff": "^1.0.0",
# "sebastian/exporter": "^1.0 || ^2.0 || ^3.0",
@@ -133,7 +131,6 @@ refactor this code.
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p0 -b .rpm
-%patch1 -p1
sed -e 's/@SYMFONY@/%{symfony_ns}/' \
%{SOURCE1} > src/PhpSpec/autoload.php
@@ -184,6 +181,9 @@ done
%changelog
+* Mon Oct 29 2018 Remi Collet <remi@remirepo.net> - 5.1.0-1
+- update to 5.1.0
+
* Mon Oct 1 2018 Remi Collet <remi@remirepo.net> - 5.0.3-1
- update to 5.0.3