summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-18 10:53:32 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-18 10:53:32 +0200
commit65e97563a193a62c45f458bafd55d2baac3e9b5e (patch)
tree441e43fad7dcaeacf8ac519cc8bd8a1d452c9b51
parent95de4d23e876eb52ca915aaa8877870854448f78 (diff)
php-phpspec: 2.5.1
-rw-r--r--composer.json64
-rw-r--r--php-phpspec.spec46
2 files changed, 98 insertions, 12 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..fbfa21e
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,64 @@
+{
+ "name": "phpspec/phpspec",
+ "description": "Specification-oriented BDD framework for PHP 5.3+",
+ "keywords": ["BDD", "SpecBDD", "TDD", "spec", "specification", "tests", "testing"],
+ "homepage": "http://phpspec.net/",
+ "type": "library",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Konstantin Kudryashov",
+ "email": "ever.zet@gmail.com",
+ "homepage": "http://everzet.com"
+ },
+ {
+ "name": "Marcello Duarte",
+ "homepage": "http://marcelloduarte.net/"
+ }
+ ],
+
+ "require": {
+ "php": ">=5.3.3",
+ "phpspec/prophecy": "~1.4",
+ "phpspec/php-diff": "~1.0.0",
+ "sebastian/exporter": "~1.0",
+ "symfony/console": "~2.3|~3.0",
+ "symfony/event-dispatcher": "~2.1|~3.0",
+ "symfony/process": "^2.6|~3.0",
+ "symfony/finder": "~2.1|~3.0",
+ "symfony/yaml": "~2.1|~3.0",
+ "doctrine/instantiator": "^1.0.1",
+ "ext-tokenizer": "*"
+ },
+
+ "require-dev": {
+ "behat/behat": "^3.0.11",
+ "symfony/filesystem": "~2.1|~3.0",
+ "phpunit/phpunit": "~4.4",
+ "ciaranmcnulty/versionbasedtestskipper": "^0.2.1"
+ },
+
+ "suggest": {
+ "phpspec/nyan-formatters": "~1.0 – Adds Nyan formatters"
+ },
+
+ "autoload": {
+ "psr-0": {
+ "PhpSpec": "src/"
+ }
+ },
+
+ "autoload-dev": {
+ "psr-0": {
+ "spec\\PhpSpec": "."
+ }
+ },
+
+ "bin": ["bin/phpspec"],
+
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.5.x-dev"
+ }
+ }
+}
diff --git a/php-phpspec.spec b/php-phpspec.spec
index 8d9ddab..9633721 100644
--- a/php-phpspec.spec
+++ b/php-phpspec.spec
@@ -6,14 +6,14 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 385ecb015e97c13818074f1517928b24d4a26067
+%global gh_commit 531d00ee76e9ae98279ed4dbb2419e5e0f7fb82d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project phpspec
#global prever beta3
Name: php-phpspec
-Version: 2.5.0
+Version: 2.5.1
Release: 1%{?dist}
Summary: Specification-oriented BDD framework for PHP
@@ -40,9 +40,10 @@ BuildRequires: php-composer(symfony/yaml) >= 2.1
BuildRequires: php-composer(doctrine/instantiator) >= 1.0.1
# From composer.json, require-dev
# "behat/behat": "^3.0.11",
-# "bossa/phpspec2-expect": "~1.0",
# "symfony/filesystem": "~2.1|~3.0",
# "phpunit/phpunit": "~4.4"
+# "phpunit/phpunit": "~4.4",
+# "ciaranmcnulty/versionbasedtestskipper": "^0.2.1"
BuildRequires: php-composer(symfony/filesystem) >= 2.1
BuildRequires: php-composer(phpunit/phpunit) >= 4.4
# For our autoloader
@@ -134,24 +135,42 @@ export LANG=en_GB.utf8
# Ignore this test which use bossa/phpspec2-expect
rm spec/PhpSpec/Message/CurrentExampleTrackerSpec.php
-%{_bindir}/php \
- -d include_path=.:%{buildroot}%{_datadir}/php \
- bin/phpspec \
- run --format pretty --verbose --no-ansi
+# remirepo:26
+run=0
+if which php56; then
+ php56 \
+ -d include_path=.:%{buildroot}%{_datadir}/php \
+ bin/phpspec \
+ run --format pretty --verbose --no-ansi
-%{_bindir}/phpunit \
- --verbose \
- --bootstrap %{buildroot}%{_datadir}/php/PhpSpec/autoload.php
+ php56 %{_bindir}/phpunit \
+ --verbose \
+ --bootstrap %{buildroot}%{_datadir}/php/PhpSpec/autoload.php
+ run=1
+fi
if which php70; then
- php70 \
+ php71 \
-d include_path=.:%{buildroot}%{_datadir}/php \
bin/phpspec \
run --format pretty --verbose --no-ansi
- php70 %{_bindir}/phpunit \
+ php71 %{_bindir}/phpunit \
--verbose \
--bootstrap %{buildroot}%{_datadir}/php/PhpSpec/autoload.php
+
+ run=1
+fi
+if [ $run -eq 0 ]; then
+%{_bindir}/php \
+ -d include_path=.:%{buildroot}%{_datadir}/php \
+ bin/phpspec \
+ run --format pretty --verbose --no-ansi
+
+%{_bindir}/phpunit \
+ --verbose \
+ --bootstrap %{buildroot}%{_datadir}/php/PhpSpec/autoload.php
+# remirepo:2
fi
%clean
@@ -169,6 +188,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Jul 18 2016 Remi Collet <remi@fedoraproject.org> - 2.5.1-1
+- update to 2.5.1
+
* Mon Mar 21 2016 Remi Collet <remi@fedoraproject.org> - 2.5.0-1
- update to 2.5.0