summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-21 08:36:00 +0200
committerRemi Collet <remi@remirepo.net>2021-06-21 08:36:00 +0200
commit40b7e392c1cc046ffb384b7e47da0eef044db7b8 (patch)
tree97e06576c13c507d6bb3fdf709bccee3459d0e05
parent1618d3799e66ecb61f4acc001861c6bbe3af7941 (diff)
update to 7.1.0
-rw-r--r--composer.json5
-rw-r--r--php-phpspec.spec13
2 files changed, 10 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 90150a3..20c0ea4 100644
--- a/composer.json
+++ b/composer.json
@@ -38,7 +38,8 @@
"require-dev": {
"behat/behat": "^3.3",
"symfony/filesystem": "^3.4 || ^4.0 || ^5.0",
- "phpunit/phpunit": "^8.0 || ^9.0"
+ "phpunit/phpunit": "^8.0 || ^9.0",
+ "vimeo/psalm": "^4.3"
},
"suggest": {
@@ -65,7 +66,7 @@
"extra": {
"branch-alias": {
- "dev-main": "7.0.x-dev"
+ "dev-main": "7.1.x-dev"
}
}
diff --git a/php-phpspec.spec b/php-phpspec.spec
index 5721e16..a78c41f 100644
--- a/php-phpspec.spec
+++ b/php-phpspec.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-phpspec
#
-# Copyright (c) 2015-2020 Remi Collet
+# Copyright (c) 2015-2021 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -13,7 +13,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 26e814250e76711235a30b6f1a7695181934f230
+%global gh_commit 30dc06a0f20642d9589bb644fbcfcb1692828699
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project phpspec
@@ -26,7 +26,7 @@
%global symfony_max 5
Name: php-phpspec
-Version: 7.0.1
+Version: 7.1.0
Release: 1%{?dist}
Summary: Specification-oriented BDD framework for PHP
@@ -64,6 +64,7 @@ BuildRequires: php-symfony4-yaml >= %{symfony_min}
# "behat/behat": "^3.3",
# "symfony/filesystem": "^3.4 || ^4.0 || ^5.0",
# "phpunit/phpunit": "^8.0 || ^9.0",
+# "vimeo/psalm": "^4.3"
BuildRequires: php-symfony4-filesystem >= %{symfony_min}
%global phpunit %{_bindir}/phpunit9
BuildRequires: %{phpunit}
@@ -160,9 +161,6 @@ export LANG=C.UTF-8
rm spec/PhpSpec/Message/CurrentExampleTrackerSpec.php
# Ignore this test which rely on composer installation
rm spec/PhpSpec/NamespaceProvider/ComposerPsrNamespaceProviderSpec.php
-# TODO investigate
-sed -e 's/it_compare_array_of_objects_to_and_displays_its_properties/skipit1/' \
- -i spec/PhpSpec/Formatter/Presenter/Differ/ArrayEngineSpec.php
for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
@@ -189,6 +187,9 @@ done
%changelog
+* Mon Jun 21 2021 Remi Collet <remi@remirepo.net> - 7.1.0-1
+- update to 7.1.0
+
* Wed Jan 6 2021 Remi Collet <remi@remirepo.net> - 7.0.1-1
- update to 7.0.1