summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-04-25 09:03:31 +0200
committerRemi Collet <remi@php.net>2023-04-25 09:03:31 +0200
commit08a1c141035d14661494ad9481eb26c4bf092c86 (patch)
tree551880da4f1b290bc605a9baef8f16be115be169
parent686d1f7833f745a2a6bdf9b5efaa6bc9bc2f4d97 (diff)
update to 7.4.0HEADmaster
allow sebastian/exporter 5 allow doctrine/instantiator 2
-rw-r--r--composer.json10
-rw-r--r--php-phpspec.spec33
2 files changed, 24 insertions, 19 deletions
diff --git a/composer.json b/composer.json
index e30ce34..e2363c5 100644
--- a/composer.json
+++ b/composer.json
@@ -25,21 +25,21 @@
"php": "^7.3 || 8.0.* || 8.1.* || 8.2.*",
"phpspec/prophecy": "^1.9",
"phpspec/php-diff": "^1.0.0",
- "sebastian/exporter": "^3.0 || ^4.0",
+ "sebastian/exporter": "^3.0 || ^4.0 || ^5.0",
"symfony/console": "^3.4 || ^4.4 || ^5.0 || ^6.0",
"symfony/event-dispatcher": "^3.4 || ^4.4 || ^5.0 || ^6.0",
"symfony/process": "^3.4 || ^4.4 || ^5.0 || ^6.0",
"symfony/finder": "^3.4 || ^4.4 || ^5.0 || ^6.0",
"symfony/yaml": "^3.4 || ^4.4 || ^5.0 || ^6.0",
- "doctrine/instantiator": "^1.0.5",
+ "doctrine/instantiator": "^1.0.5 || ^2",
"ext-tokenizer": "*"
},
"require-dev": {
"behat/behat": "^3.3",
"symfony/filesystem": "^3.4 || ^4.0 || ^5.0 || ^6.0",
- "phpunit/phpunit": "^8.0 || ^9.0",
- "vimeo/psalm": "^4.3"
+ "phpunit/phpunit": "^8.0 || ^9.0 || ^10.0",
+ "vimeo/psalm": "^4.3 || ^5.2"
},
"suggest": {
@@ -66,7 +66,7 @@
"extra": {
"branch-alias": {
- "dev-main": "7.3.x-dev"
+ "dev-main": "7.4.x-dev"
}
}
diff --git a/php-phpspec.spec b/php-phpspec.spec
index 47dd743..013410b 100644
--- a/php-phpspec.spec
+++ b/php-phpspec.spec
@@ -1,7 +1,7 @@
# remirepo/fedora spec file for php-phpspec
#
-# Copyright (c) 2015-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2015-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -13,7 +13,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 7e44b188e8e01f9c9a8ca6cb0d7aceaabcea2133
+%global gh_commit 28faa87d1151a15848166226f33de61cb7107d0d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project phpspec
@@ -26,7 +26,7 @@
%global symfony_max 5
Name: php-phpspec
-Version: 7.3.0
+Version: 7.4.0
Release: 1%{?dist}
Summary: Specification-oriented BDD framework for PHP
@@ -47,8 +47,8 @@ BuildRequires: php(language) >= 7.3
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(phpspec/prophecy) >= 1.9 with php-composer(phpspec/prophecy) < 2)
BuildRequires: (php-composer(phpspec/php-diff) >= 1.0.0 with php-composer(phpspec/php-diff) < 2)
-BuildRequires: (php-composer(sebastian/exporter) >= 3 with php-composer(sebastian/exporter) < 5)
-BuildRequires: (php-composer(doctrine/instantiator) >= 1.0.5 with php-composer(doctrine/instantiator) < 2)
+BuildRequires: (php-composer(sebastian/exporter) >= 3 with php-composer(sebastian/exporter) < 6)
+BuildRequires: (php-composer(doctrine/instantiator) >= 1.0.5 with php-composer(doctrine/instantiator) < 3)
# remirepo:6
%else
BuildRequires: php-phpspec-prophecy >= 1.9
@@ -64,9 +64,10 @@ BuildRequires: php-symfony4-yaml >= %{symfony_min}
# From composer.json, require-dev
# "behat/behat": "^3.3",
# "symfony/filesystem": "^3.4 || ^4.0 || ^5.0 || ^6.0",
-# "phpunit/phpunit": "^8.0 || ^9.0",
-# "vimeo/psalm": "^4.3"
+# "phpunit/phpunit": "^8.0 || ^9.0 || ^10.0",
+# "vimeo/psalm": "^4.3 || ^5.2"
BuildRequires: php-symfony4-filesystem >= %{symfony_min}
+# keep v9 for PHP 8.0 and until v10 approved
%global phpunit %{_bindir}/phpunit9
BuildRequires: %{phpunit}
%endif
@@ -77,13 +78,13 @@ BuildRequires: php-composer(fedora/autoloader) >= 1
# "php": "^7.3 || 8.0.* || 8.1.* || 8.2.*",
# "phpspec/prophecy": "^1.9",
# "phpspec/php-diff": "^1.0.0",
-# "sebastian/exporter": "^3.0 || ^4.0",
+# "sebastian/exporter": "^3.0 || ^4.0 || ^5.0",
# "symfony/console": "^3.4 || ^4.4 || ^5.0 || ^6.0",
# "symfony/event-dispatcher": "^3.4 || ^4.4 || ^5.0 || ^6.0",
# "symfony/process": "^3.4 || ^4.4 || ^5.0 || ^6.0",
# "symfony/finder": "^3.4 || ^4.4 || ^5.0 || ^6.0",
# "symfony/yaml": "^3.4 || ^4.4 || ^5.0 || ^6.0",
-# "doctrine/instantiator": "^1.0.5"
+# "doctrine/instantiator": "^1.0.5 || ^2"
# "ext-tokenizer": "*"
Requires: php(language) >= 7.3
@@ -91,8 +92,8 @@ Requires: php(language) >= 7.3
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(phpspec/prophecy) >= 1.9 with php-composer(phpspec/prophecy) < 2)
Requires: (php-composer(phpspec/php-diff) >= 1.0.0 with php-composer(phpspec/php-diff) < 2)
-Requires: (php-composer(sebastian/exporter) >= 3 with php-composer(sebastian/exporter) < 5)
-Requires: (php-composer(doctrine/instantiator) >= 1.0.5 with php-composer(doctrine/instantiator) < 2)
+Requires: (php-composer(sebastian/exporter) >= 3 with php-composer(sebastian/exporter) < 6)
+Requires: (php-composer(doctrine/instantiator) >= 1.0.5 with php-composer(doctrine/instantiator) < 3)
# remirepo:6
%else
Requires: php-phpspec-prophecy >= 1.9
@@ -168,10 +169,9 @@ for cmdarg in "php %{phpunit}" php80 php81 php82; do
set $cmdarg
$1 -d memory_limit=1G -d include_path=.:%{buildroot}%{_datadir}/php \
bin/phpspec \
- run --format pretty --verbose --no-ansi
+ run --format pretty --no-ansi
$1 ${2:-%{_bindir}/phpunit9} \
- --verbose \
--bootstrap %{buildroot}%{_datadir}/php/PhpSpec/autoload.php
fi
done
@@ -188,6 +188,11 @@ done
%changelog
+* Tue Apr 25 2023 Remi Collet <remi@remirepo.net> - 7.4.0-1
+- update to 7.4.0
+- allow sebastian/exporter 5
+- allow doctrine/instantiator 2
+
* Thu Dec 15 2022 Remi Collet <remi@remirepo.net> - 7.3.0-1
- update to 7.3.0