summaryrefslogtreecommitdiffstats
path: root/php-phpspec-prophecy.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpspec-prophecy.spec')
-rw-r--r--php-phpspec-prophecy.spec38
1 files changed, 11 insertions, 27 deletions
diff --git a/php-phpspec-prophecy.spec b/php-phpspec-prophecy.spec
index c55977e..2e5f05e 100644
--- a/php-phpspec-prophecy.spec
+++ b/php-phpspec-prophecy.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-phpspec-prophecy
#
-# Copyright (c) 2015-2023 Remi Collet
+# Copyright (c) 2015-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
-%global gh_commit 67a759e7d8746d501c41536ba40cd9c0a07d6a87
+%global gh_commit a0165c648cab6a80311c74ffc708a07bb53ecc93
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project prophecy
@@ -15,7 +15,7 @@
%bcond_with phpspec
Name: php-phpspec-prophecy
-Version: 1.19.0
+Version: 1.20.0
Release: 1%{?dist}
Summary: Highly opinionated mocking framework for PHP
@@ -27,20 +27,12 @@ Source2: makesrc.sh
BuildArch: noarch
BuildRequires: php(language) >= 7.2
%if %{with tests}
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(phpdocumentor/reflection-docblock) >= 5.2 with php-composer(phpdocumentor/reflection-docblock) < 6)
BuildRequires: (php-composer(sebastian/comparator) >= 3.0 with php-composer(sebastian/comparator) < 7)
BuildRequires: (php-composer(sebastian/recursion-context) >= 3.0 with php-composer(sebastian/recursion-context) < 7)
BuildRequires: (php-composer(doctrine/instantiator) >= 1.2 with php-composer(doctrine/instantiator) < 3)
-# remirepo:6
-%else
-BuildRequires: php-phpdocumentor-reflection-docblock5 >= 5.2
-BuildRequires: php-sebastian-comparator3
-BuildRequires: php-sebastian-recursion-context3
-BuildRequires: php-doctrine-instantiator >= 1.2
-%endif
# from composer.json, "require-dev": {
+# "friendsofphp/php-cs-fixer": "^3.40",
# "phpspec/phpspec": "^6.0 || ^7.0"
# "phpstan/phpstan": "^1.9",
# "phpunit/phpunit": "^8.0 || ^9.0 || ^10.0"
@@ -59,25 +51,16 @@ BuildRequires: phpunit11
BuildRequires: php-fedora-autoloader-devel
# from composer.json, "requires": {
-# "php": "^7.2 || 8.0.* || 8.1.* || 8.2.* || 8.3.*",
+# "php": "^7.2 || 8.0.* || 8.1.* || 8.2.* || 8.3.* || 8.4.*",
# "phpdocumentor/reflection-docblock": "^5.2",
# "sebastian/comparator": "^3.0 || ^4.0 || ^5.0 || ^6.0",
# "doctrine/instantiator": "^1.2 || ^2.0",
# "sebastian/recursion-context": "^3.0 || ^4.0 || ^5.0 || ^6.0"
Requires: php(language) >= 7.2
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(phpdocumentor/reflection-docblock) >= 5.2 with php-composer(phpdocumentor/reflection-docblock) < 6)
Requires: (php-composer(sebastian/comparator) >= 3.0 with php-composer(sebastian/comparator) < 7)
Requires: (php-composer(sebastian/recursion-context) >= 3.0 with php-composer(sebastian/recursion-context) < 7)
Requires: (php-composer(doctrine/instantiator) >= 1.2 with php-composer(doctrine/instantiator) < 3)
-# remirepo:6
-%else
-Requires: php-phpdocumentor-reflection-docblock5 >= 5.2
-Requires: php-sebastian-comparator3
-Requires: php-sebastian-recursion-context3
-Requires: php-doctrine-instantiator >= 1.2
-%endif
# From phpcompatinfo report for version 1.11.0
Requires: php-pcre
Requires: php-reflection
@@ -166,7 +149,7 @@ phpspec --version
ret=0
# ignore it_can_not_double_an_enum on all version. Not ready
-for cmd in php php81 php82 php83; do
+for cmd in php php81 php82 php83 php84; do
if which $cmd; then
%if %{with phpspec}
$cmd -d auto_prepend_file=vendor/autoload.php \
@@ -183,9 +166,9 @@ for cmd in php php81 php82 php83; do
|| ret=1
fi
done
-# remirepo:7
+# remirepo:9
%if 0%{?fedora} >= 38 || 0%{?rhel} >= 10
-for cmd in php php82 php83; do
+for cmd in php php82 php83 php84; do
if which $cmd; then
$cmd -d auto_prepend_file=vendor/autoload.php \
%{_bindir}/phpunit11 \
@@ -200,8 +183,6 @@ exit $ret
%files
-# remirepo:1
-%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
%doc composer.json
@@ -209,6 +190,9 @@ exit $ret
%changelog
+* Thu Nov 21 2024 Remi Collet <remi@remirepo.net> - 1.20.0-1
+- update to 1.20.0
+
* Thu Feb 29 2024 Remi Collet <remi@remirepo.net> - 1.19.0-1
- update to 1.19.0
- allow doctrine/instantiator 6