summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--php-phpspec-prophecy.spec11
2 files changed, 9 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index bb3d372..816f147 100644
--- a/composer.json
+++ b/composer.json
@@ -27,7 +27,7 @@
"require-dev": {
"phpspec/phpspec": "^2.5|^3.2",
- "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.5"
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.5 || ^7.1"
},
"autoload": {
@@ -44,7 +44,7 @@
"extra": {
"branch-alias": {
- "dev-master": "1.7.x-dev"
+ "dev-master": "1.8.x-dev"
}
}
}
diff --git a/php-phpspec-prophecy.spec b/php-phpspec-prophecy.spec
index 1ea7657..d9e227f 100644
--- a/php-phpspec-prophecy.spec
+++ b/php-phpspec-prophecy.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 33a7e3c4fda54e912ff6338c48823bd5c0f0b712
+%global gh_commit 4ba436b55987b4bf311cb7c6ba82aa528aac0a06
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project prophecy
@@ -19,7 +19,7 @@
%endif
Name: php-phpspec-prophecy
-Version: 1.7.6
+Version: 1.8.0
Release: 1%{?dist}
Summary: Highly opinionated mocking framework for PHP
@@ -35,7 +35,7 @@ BuildArch: noarch
%if %{with_tests}
# from composer.json, "require-dev": {
# "phpspec/phpspec": "^2.5|^3.2"
-# "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.5"
+# "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.5 || ^7.1"
BuildRequires: php-composer(phpspec/phpspec) >= 2.5
# Autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -115,7 +115,7 @@ if [ $VER -ge 4 ]; then
fi
ret=0
-for cmd in php php70 php71 php72; do
+for cmd in php php70 php71 php72 php73; do
if which $cmd; then
$cmd -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
%{_bindir}/phpspec run --format pretty --verbose --no-ansi || ret=1
@@ -136,6 +136,9 @@ exit $ret
%changelog
+* Mon Aug 20 2018 Remi Collet <remi@remirepo.net> - 1.8.0-1
+- update to 1.8.0
+
* Thu Apr 19 2018 Remi Collet <remi@remirepo.net> - 1.7.6-1
- update to 1.7.6