summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-12 07:18:55 +0100
committerRemi Collet <remi@remirepo.net>2018-02-12 07:18:55 +0100
commitf3d833a4ec412609d7b31cb277fd0ed367f1898a (patch)
treeb92b6f4341226477debcb7e0ab7e8870990af5c3
parent2387242d0aeff63203aff34664431c405ce16379 (diff)
Update to 1.7.4
use range dependency on F27+
-rw-r--r--composer.json2
-rw-r--r--php-phpspec-prophecy-autoload.php4
-rw-r--r--php-phpspec-prophecy.spec22
3 files changed, 21 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 5bdbdb3..2bea646 100644
--- a/composer.json
+++ b/composer.json
@@ -27,7 +27,7 @@
"require-dev": {
"phpspec/phpspec": "^2.5|^3.2",
- "phpunit/phpunit": "^4.8.35 || ^5.7"
+ "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.5"
},
"autoload": {
diff --git a/php-phpspec-prophecy-autoload.php b/php-phpspec-prophecy-autoload.php
index 599ad20..0698ea8 100644
--- a/php-phpspec-prophecy-autoload.php
+++ b/php-phpspec-prophecy-autoload.php
@@ -9,7 +9,9 @@ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
// Dependencies
require_once 'Doctrine/Instantiator/autoload.php';
-if ($dep = stream_resolve_include_path('phpDocumentor/Reflection/DocBlock/autoload.php')) {
+if ($dep = stream_resolve_include_path('phpDocumentor/Reflection/DocBlock4/autoload.php')) {
+ require_once $dep;
+} else if ($dep = stream_resolve_include_path('phpDocumentor/Reflection/DocBlock/autoload.php')) {
require_once $dep;
} else if ($dep = stream_resolve_include_path('phpDocumentor/Reflection/DocBlock2/autoload.php')) {
require_once $dep;
diff --git a/php-phpspec-prophecy.spec b/php-phpspec-prophecy.spec
index 54a6c07..eb69f58 100644
--- a/php-phpspec-prophecy.spec
+++ b/php-phpspec-prophecy.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-phpspec-prophecy
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit e4ed002c67da8eceb0eb8ddb8b3847bb53c5c2bf
+%global gh_commit 9f901e29c93dae4aa77c0bb161df4276f9c9a1be
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project prophecy
@@ -19,11 +19,10 @@
%endif
Name: php-phpspec-prophecy
-Version: 1.7.3
+Version: 1.7.4
Release: 1%{?dist}
Summary: Highly opinionated mocking framework for PHP
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{gh_short}.tgz
@@ -36,7 +35,7 @@ BuildArch: noarch
%if %{with_tests}
# from composer.json, "require-dev": {
# "phpspec/phpspec": "^2.5|^3.2"
-# "phpunit/phpunit": "^4.8.35 || ^5.7"
+# "phpunit/phpunit": "^4.8.35 || ^5.7 || ^6.5"
BuildRequires: php-composer(phpspec/phpspec) >= 2.5
# Autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -49,6 +48,14 @@ BuildRequires: php-composer(fedora/autoloader)
# "doctrine/instantiator": "^1.0.2",
# "sebastian/recursion-context": "^1.0|^2.0|^3.0"
Requires: php(language) >= 5.3
+%if 0%{?fedora} >= 27
+Requires: (php-composer(phpdocumentor/reflection-docblock) >= 2.0 with php-composer(phpdocumentor/reflection-docblock) < 5)
+Requires: (php-composer(sebastian/comparator) >= 1.1 with php-composer(sebastian/comparator) < 3)
+# recursion-context will be pulled by phpspec or phpunit or phpunit6
+#Requires: (php-composer(sebastian/recursion-context) >= 1.0 with php-composer(sebastian/recursion-context) < 4)
+# use 1.0.4 to ensure we have the autoloader
+Requires: (php-composer(doctrine/instantiator) >= 1.0.4 with php-composer(doctrine/instantiator) < 2)
+%else
Requires: php-composer(phpdocumentor/reflection-docblock) >= 2.0
# ignore v4 for now
Requires: php-composer(phpdocumentor/reflection-docblock) < 4
@@ -60,6 +67,7 @@ Requires: php-composer(sebastian/comparator) < 3
# use 1.0.4 to ensure we have the autoloader
Requires: php-composer(doctrine/instantiator) >= 1.0.4
Requires: php-composer(doctrine/instantiator) < 2
+%endif
# From phpcompatinfo report for version 1.1.0
Requires: php-pcre
Requires: php-reflection
@@ -124,6 +132,10 @@ exit $ret
%changelog
+* Mon Feb 12 2018 Remi Collet <remi@remirepo.net> - 1.7.4-1
+- Update to 1.7.4
+- use range dependency on F27+
+
* Mon Nov 27 2017 Remi Collet <remi@remirepo.net> - 1.7.3-1
- Update to 1.7.3