summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-02-17 15:27:46 +0100
committerRemi Collet <fedora@famillecollet.com>2015-02-17 15:27:46 +0100
commite69dcea0e01405178808be8de45c4d6fb08df6ba (patch)
treeb40e444b3ab77e55fd247608423a09145c8afc3e
parent1c4bbb87f7be72737f30a1e349f4dd246282b338 (diff)
php-phpspec-prophecy: fix include path during for tests
-rw-r--r--php-phpspec-prophecy.spec7
1 files changed, 5 insertions, 2 deletions
diff --git a/php-phpspec-prophecy.spec b/php-phpspec-prophecy.spec
index ee56e77..bb5df6e 100644
--- a/php-phpspec-prophecy.spec
+++ b/php-phpspec-prophecy.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global bootstrap 1
+%global bootstrap 1
%global gh_commit 9ca52329bcdd1500de24427542577ebf3fc2f1c9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
@@ -83,7 +83,10 @@ cp -pr src/* %{buildroot}%{_datadir}/php
%check
%if %{with_tests}
-%{_bindir}/phpspec run --format pretty --verbose --no-ansi
+%{_bindir}/php \
+ -d include_path=.:%{buildroot}%{_datadir}/php:/usr/share/php \
+ %{_bindir}/phpspec \
+ run --format pretty --verbose --no-ansi
%else
: Test suite disabled
%endif