summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-19 15:46:22 +0200
committerRemi Collet <remi@remirepo.net>2018-04-19 15:46:22 +0200
commitde6520c626b3def89bc79034c083a4b46ec033ed (patch)
tree0a5903064835964105679e9b312b31a916c809cd
parent390f757799e3aa635f23b1d75885dc29e96777a5 (diff)
v1.7.6
-rw-r--r--composer.json2
-rw-r--r--php-phpspec-prophecy-autoload.php4
-rw-r--r--php-phpspec-prophecy.spec15
3 files changed, 15 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 2bea646..bb3d372 100644
--- a/composer.json
+++ b/composer.json
@@ -20,7 +20,7 @@
"require": {
"php": "^5.3|^7.0",
"phpdocumentor/reflection-docblock": "^2.0|^3.0.2|^4.0",
- "sebastian/comparator": "^1.1|^2.0",
+ "sebastian/comparator": "^1.1|^2.0|^3.0",
"doctrine/instantiator": "^1.0.2",
"sebastian/recursion-context": "^1.0|^2.0|^3.0"
},
diff --git a/php-phpspec-prophecy-autoload.php b/php-phpspec-prophecy-autoload.php
index 0698ea8..3a2b120 100644
--- a/php-phpspec-prophecy-autoload.php
+++ b/php-phpspec-prophecy-autoload.php
@@ -22,7 +22,9 @@ if ($dep = stream_resolve_include_path('phpDocumentor/Reflection/DocBlock4/autol
unset($dep);
if (!class_exists('SebastianBergmann\\Comparator\\Comparator')) { // v2 from phpunit, v1 from phpspec
- require_once (stream_resolve_include_path('SebastianBergmann/Comparator2/autoload.php') ?: 'SebastianBergmann/Comparator/autoload.php');
+ require_once (stream_resolve_include_path('SebastianBergmann/Comparator3/autoload.php') ?:
+ (stream_resolve_include_path('SebastianBergmann/Comparator2/autoload.php') ?:
+ 'SebastianBergmann/Comparator/autoload.php'));
}
if (!class_exists('SebastianBergmann\\RecursionContext\\Context')) { // v3 from phpunit, v2 from phpspec (via exporter)
require_once (stream_resolve_include_path('SebastianBergmann/RecursionContext3/autoload.php') ?: 'SebastianBergmann/RecursionContext/autoload.php');
diff --git a/php-phpspec-prophecy.spec b/php-phpspec-prophecy.spec
index c19ce79..1ea7657 100644
--- a/php-phpspec-prophecy.spec
+++ b/php-phpspec-prophecy.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit dfd6be44111a7c41c2e884a336cc4f461b3b2401
+%global gh_commit 33a7e3c4fda54e912ff6338c48823bd5c0f0b712
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project prophecy
@@ -19,7 +19,7 @@
%endif
Name: php-phpspec-prophecy
-Version: 1.7.5
+Version: 1.7.6
Release: 1%{?dist}
Summary: Highly opinionated mocking framework for PHP
@@ -44,13 +44,13 @@ BuildRequires: php-composer(fedora/autoloader)
# from composer.json, "requires": {
# "php": "^5.3|^7.0",
# "phpdocumentor/reflection-docblock": "^2.0|^3.0.2|^4.0",
-# "sebastian/comparator": "^1.1|^2.0",
+# "sebastian/comparator": "^1.1|^2.0|^3.0",
# "doctrine/instantiator": "^1.0.2",
# "sebastian/recursion-context": "^1.0|^2.0|^3.0"
Requires: php(language) >= 5.3
%if 0%{?fedora} >= 27
Requires: (php-composer(phpdocumentor/reflection-docblock) >= 2.0 with php-composer(phpdocumentor/reflection-docblock) < 5)
-Requires: (php-composer(sebastian/comparator) >= 1.1 with php-composer(sebastian/comparator) < 3)
+Requires: (php-composer(sebastian/comparator) >= 1.1 with php-composer(sebastian/comparator) < 4)
# recursion-context will be pulled by phpspec or phpunit or phpunit6
#Requires: (php-composer(sebastian/recursion-context) >= 1.0 with php-composer(sebastian/recursion-context) < 4)
# use 1.0.4 to ensure we have the autoloader
@@ -103,6 +103,10 @@ cp -pr src/* %{buildroot}%{_datadir}/php
%check
%if %{with_tests}
+: check autoloader
+php %{buildroot}%{_datadir}/php/Prophecy/autoload.php
+
+: check phpspec
phpspec --version
VER=$(phpspec --version | sed -n -e 's/.* //;s/\..*$//;p')
if [ $VER -ge 4 ]; then
@@ -132,6 +136,9 @@ exit $ret
%changelog
+* Thu Apr 19 2018 Remi Collet <remi@remirepo.net> - 1.7.6-1
+- update to 1.7.6
+
* Tue Feb 20 2018 Remi Collet <remi@remirepo.net> - 1.7.5-1
- Update to 1.7.5