summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-10-28 07:51:39 +0100
committerRemi Collet <fedora@famillecollet.com>2015-10-28 07:51:39 +0100
commitcd49dddbe047114224caa56a8bedf938c2cd200d (patch)
tree6abaa6b3943c885e185573db0ce66dee0678ecdd
parentb5992fe44144871f99bda2e7d4c74d0231a536e4 (diff)
php-phpspec-prophecy: fix autoloader
-rw-r--r--php-phpspec-prophecy-autoload.php7
-rw-r--r--php-phpspec-prophecy.spec7
2 files changed, 9 insertions, 5 deletions
diff --git a/php-phpspec-prophecy-autoload.php b/php-phpspec-prophecy-autoload.php
index 1e8dfe4..473319b 100644
--- a/php-phpspec-prophecy-autoload.php
+++ b/php-phpspec-prophecy-autoload.php
@@ -1,11 +1,12 @@
<?php
/* Autoloader for phpspec/prophecy and its dependencies */
-$vendorDir = '/usr/share/php';
+// Rely on include_path as in PHPUnit dependencies + circular dependencies
+
// Use Symfony autoloader
if (!isset($fedoraClassLoader) || !($fedoraClassLoader instanceof \Symfony\Component\ClassLoader\ClassLoader)) {
if (!class_exists('Symfony\\Component\\ClassLoader\\ClassLoader', false)) {
- require_once $vendorDir . '/Symfony/Component/ClassLoader/ClassLoader.php';
+ require_once 'Symfony/Component/ClassLoader/ClassLoader.php';
}
$fedoraClassLoader = new \Symfony\Component\ClassLoader\ClassLoader();
@@ -14,7 +15,7 @@ if (!isset($fedoraClassLoader) || !($fedoraClassLoader instanceof \Symfony\Compo
$fedoraClassLoader->addPrefix('Prophecy\\', dirname(__DIR__));
-// Depdencies (Rely on include_path as in PHPUnit dependencies + circular dependencies)
+// Dependencies
require_once 'Doctrine/Instantiator/autoload.php';
require_once 'SebastianBergmann/Comparator/autoload.php';
require_once 'phpDocumentor/Reflection/DocBlock/autoload.php';
diff --git a/php-phpspec-prophecy.spec b/php-phpspec-prophecy.spec
index a4548f5..2b977a7 100644
--- a/php-phpspec-prophecy.spec
+++ b/php-phpspec-prophecy.spec
@@ -20,7 +20,7 @@
Name: php-phpspec-prophecy
Version: 1.5.0
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: Highly opinionated mocking framework for PHP
Group: Development/Libraries
@@ -88,7 +88,7 @@ cp -pr src/* %{buildroot}%{_datadir}/php
%check
%if %{with_tests}
%{_bindir}/php \
- -d include_path=.:%{buildroot}%{_datadir}/php:/usr/share/php \
+ -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
%{_bindir}/phpspec \
run --format pretty --verbose --no-ansi
%else
@@ -110,6 +110,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Oct 28 2015 Remi Collet <remi@fedoraproject.org> - 1.5.0-2
+- fix autolaoder, rely on include_path for symfony/class-loader
+
* Thu Aug 13 2015 Remi Collet <remi@fedoraproject.org> - 1.5.0-1
- update to 1.5.0