summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2025-04-30 07:38:39 +0200
committerRemi Collet <remi@php.net>2025-04-30 07:38:39 +0200
commit98f9ce9bdab6d4ff7e595dc1c43a0c3ddbc4880f (patch)
treebe970ae0c2791f1d0dc9cb2375aad6644caa9090
parent337a285ed69941b2f35b2480cf3646153bc4bb70 (diff)
update to 1.22.0HEADmaster
re-license spec file to CECILL-2.1
-rw-r--r--composer.json8
-rw-r--r--php-phpspec-prophecy.spec59
2 files changed, 44 insertions, 23 deletions
diff --git a/composer.json b/composer.json
index d520edb..219f211 100644
--- a/composer.json
+++ b/composer.json
@@ -18,17 +18,17 @@
],
"require": {
- "php": "^7.2 || 8.0.* || 8.1.* || 8.2.* || 8.3.* || 8.4.*",
+ "php": "^7.4 || 8.0.* || 8.1.* || 8.2.* || 8.3.* || 8.4.*",
"phpdocumentor/reflection-docblock": "^5.2",
- "sebastian/comparator": "^3.0 || ^4.0 || ^5.0 || ^6.0",
+ "sebastian/comparator": "^3.0 || ^4.0 || ^5.0 || ^6.0 || ^7.0",
"doctrine/instantiator": "^1.2 || ^2.0",
- "sebastian/recursion-context": "^3.0 || ^4.0 || ^5.0 || ^6.0"
+ "sebastian/recursion-context": "^3.0 || ^4.0 || ^5.0 || ^6.0 || ^7.0"
},
"require-dev": {
"friendsofphp/php-cs-fixer": "^3.40",
"phpspec/phpspec": "^6.0 || ^7.0",
- "phpstan/phpstan": "^1.9",
+ "phpstan/phpstan": "^2.1.13",
"phpunit/phpunit": "^8.0 || ^9.0 || ^10.0"
},
diff --git a/php-phpspec-prophecy.spec b/php-phpspec-prophecy.spec
index 2e5f05e..092d36e 100644
--- a/php-phpspec-prophecy.spec
+++ b/php-phpspec-prophecy.spec
@@ -1,12 +1,12 @@
# remirepo/fedora spec file for php-phpspec-prophecy
#
-# Copyright (c) 2015-2024 Remi Collet
-# License: CC-BY-SA-4.0
-# http://creativecommons.org/licenses/by-sa/4.0/
+# SPDX-FileCopyrightText: Copyright 2015-2025 Remi Collet
+# SPDX-License-Identifier: CECILL-2.1
+# http://www.cecill.info/licences/Licence_CeCILL_V2-en.txt
#
# Please, preserve the changelog entries
#
-%global gh_commit a0165c648cab6a80311c74ffc708a07bb53ecc93
+%global gh_commit 35f1adb388946d92e6edab2aa2cb2b60e132ebd5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project prophecy
@@ -15,7 +15,7 @@
%bcond_with phpspec
Name: php-phpspec-prophecy
-Version: 1.20.0
+Version: 1.22.0
Release: 1%{?dist}
Summary: Highly opinionated mocking framework for PHP
@@ -25,16 +25,16 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source2: makesrc.sh
BuildArch: noarch
-BuildRequires: php(language) >= 7.2
+BuildRequires: php(language) >= 7.4
%if %{with tests}
BuildRequires: (php-composer(phpdocumentor/reflection-docblock) >= 5.2 with php-composer(phpdocumentor/reflection-docblock) < 6)
-BuildRequires: (php-composer(sebastian/comparator) >= 3.0 with php-composer(sebastian/comparator) < 7)
-BuildRequires: (php-composer(sebastian/recursion-context) >= 3.0 with php-composer(sebastian/recursion-context) < 7)
+BuildRequires: (php-composer(sebastian/comparator) >= 3.0 with php-composer(sebastian/comparator) < 8)
+BuildRequires: (php-composer(sebastian/recursion-context) >= 3.0 with php-composer(sebastian/recursion-context) < 8)
BuildRequires: (php-composer(doctrine/instantiator) >= 1.2 with php-composer(doctrine/instantiator) < 3)
# from composer.json, "require-dev": {
# "friendsofphp/php-cs-fixer": "^3.40",
# "phpspec/phpspec": "^6.0 || ^7.0"
-# "phpstan/phpstan": "^1.9",
+# "phpstan/phpstan": "^2.1.13",
# "phpunit/phpunit": "^8.0 || ^9.0 || ^10.0"
%if %{with phpspec}
BuildRequires: php-composer(phpspec/phpspec) >= 6.0
@@ -42,24 +42,26 @@ BuildRequires: php-composer(phpspec/phpspec) >= 6.0
BuildRequires: phpunit8
BuildRequires: phpunit9
BuildRequires: phpunit10
-# remirepo:3
-%if 0%{?fedora} >= 38 || 0%{?rhel} >= 10
+# remirepo:1
+%if 0%{?fedora} >= 40 || 0%{?rhel} >= 10
BuildRequires: phpunit11
+BuildRequires: phpunit12
+# remirepo:1
%endif
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# from composer.json, "requires": {
-# "php": "^7.2 || 8.0.* || 8.1.* || 8.2.* || 8.3.* || 8.4.*",
+# "php": "^7.4 || 8.0.* || 8.1.* || 8.2.* || 8.3.* || 8.4.*",
# "phpdocumentor/reflection-docblock": "^5.2",
-# "sebastian/comparator": "^3.0 || ^4.0 || ^5.0 || ^6.0",
+# "sebastian/comparator": "^3.0 || ^4.0 || ^5.0 || ^6.0 || ^7.0",
# "doctrine/instantiator": "^1.2 || ^2.0",
-# "sebastian/recursion-context": "^3.0 || ^4.0 || ^5.0 || ^6.0"
-Requires: php(language) >= 7.2
+# "sebastian/recursion-context": "^3.0 || ^4.0 || ^5.0 || ^6.0 || ^7.0"
+Requires: php(language) >= 7.4
Requires: (php-composer(phpdocumentor/reflection-docblock) >= 5.2 with php-composer(phpdocumentor/reflection-docblock) < 6)
-Requires: (php-composer(sebastian/comparator) >= 3.0 with php-composer(sebastian/comparator) < 7)
-Requires: (php-composer(sebastian/recursion-context) >= 3.0 with php-composer(sebastian/recursion-context) < 7)
+Requires: (php-composer(sebastian/comparator) >= 3.0 with php-composer(sebastian/comparator) < 8)
+Requires: (php-composer(sebastian/recursion-context) >= 3.0 with php-composer(sebastian/recursion-context) < 8)
Requires: (php-composer(doctrine/instantiator) >= 1.2 with php-composer(doctrine/instantiator) < 3)
# From phpcompatinfo report for version 1.11.0
Requires: php-pcre
@@ -106,6 +108,9 @@ if (!class_exists('SebastianBergmann\\Comparator\\Comparator')) { // v2 from php
if (PHP_VERSION_ID > 80200) {
array_unshift($inst, '%{_datadir}/php/SebastianBergmann/Comparator6/autoload.php');
}
+ if (PHP_VERSION_ID > 80300) {
+ array_unshift($inst, '%{_datadir}/php/SebastianBergmann/Comparator7/autoload.php');
+ }
\Fedora\Autoloader\Dependencies::required([$inst]);
}
if (!class_exists('SebastianBergmann\\RecursionContext\\Context')) { // v2 from phpunit, v1 from phpspec
@@ -119,6 +124,9 @@ if (!class_exists('SebastianBergmann\\RecursionContext\\Context')) { // v2 from
if (PHP_VERSION_ID > 80200) {
array_unshift($inst, '%{_datadir}/php/SebastianBergmann/RecursionContext6/autoload.php');
}
+ if (PHP_VERSION_ID > 80300) {
+ array_unshift($inst, '%{_datadir}/php/SebastianBergmann/RecursionContext7/autoload.php');
+ }
\Fedora\Autoloader\Dependencies::required([$inst]);
}
EOF
@@ -166,8 +174,8 @@ for cmd in php php81 php82 php83 php84; do
|| ret=1
fi
done
-# remirepo:9
-%if 0%{?fedora} >= 38 || 0%{?rhel} >= 10
+# remirepo:1
+%if 0%{?fedora} >= 40 || 0%{?rhel} >= 10
for cmd in php php82 php83 php84; do
if which $cmd; then
$cmd -d auto_prepend_file=vendor/autoload.php \
@@ -175,6 +183,15 @@ for cmd in php php82 php83 php84; do
|| ret=1
fi
done
+# Not ready see https://github.com/phpspec/prophecy/issues/640
+for cmd in php php83 php84; do
+ if which $cmd; then
+ $cmd -d auto_prepend_file=vendor/autoload.php \
+ %{_bindir}/phpunit12 \
+ || ignore=1
+ fi
+done
+# remirepo:1
%endif
exit $ret
%else
@@ -190,6 +207,10 @@ exit $ret
%changelog
+* Wed Apr 30 2025 Remi Collet <remi@remirepo.net> - 1.22.0-1
+- update to 1.22.0
+- re-license spec file to CECILL-2.1
+
* Thu Nov 21 2024 Remi Collet <remi@remirepo.net> - 1.20.0-1
- update to 1.20.0