summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-06-13 15:38:29 +0200
committerRemi Collet <remi@remirepo.net>2019-06-13 15:38:29 +0200
commit514f9c09c03835c50a91379585496ac9cdd33b82 (patch)
tree704ffab0790224f3436738989b7a498fbe56c228
parentadda6e08fa2c7d3fa8537c1a57788decf191678c (diff)
v1.8.1
-rw-r--r--composer.json4
-rw-r--r--php-phpspec-prophecy.spec16
2 files changed, 13 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 816f147..13b6658 100644
--- a/composer.json
+++ b/composer.json
@@ -31,8 +31,8 @@
},
"autoload": {
- "psr-0": {
- "Prophecy\\": "src/"
+ "psr-4": {
+ "Prophecy\\": "src/Prophecy"
}
},
diff --git a/php-phpspec-prophecy.spec b/php-phpspec-prophecy.spec
index d9e227f..c67dc2a 100644
--- a/php-phpspec-prophecy.spec
+++ b/php-phpspec-prophecy.spec
@@ -1,13 +1,13 @@
# remirepo/fedora spec file for php-phpspec-prophecy
#
-# Copyright (c) 2015-2018 Remi Collet
+# Copyright (c) 2015-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 4ba436b55987b4bf311cb7c6ba82aa528aac0a06
+%global gh_commit 1927e75f4ed19131ec9bcc3b002e07fb1173ee76
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project prophecy
@@ -19,7 +19,7 @@
%endif
Name: php-phpspec-prophecy
-Version: 1.8.0
+Version: 1.8.1
Release: 1%{?dist}
Summary: Highly opinionated mocking framework for PHP
@@ -48,7 +48,7 @@ BuildRequires: php-composer(fedora/autoloader)
# "doctrine/instantiator": "^1.0.2",
# "sebastian/recursion-context": "^1.0|^2.0|^3.0"
Requires: php(language) >= 5.3
-%if 0%{?fedora} >= 27
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(phpdocumentor/reflection-docblock) >= 2.0 with php-composer(phpdocumentor/reflection-docblock) < 5)
Requires: (php-composer(sebastian/comparator) >= 1.1 with php-composer(sebastian/comparator) < 4)
# recursion-context will be pulled by phpspec or phpunit or phpunit6
@@ -115,7 +115,7 @@ if [ $VER -ge 4 ]; then
fi
ret=0
-for cmd in php php70 php71 php72 php73; do
+for cmd in php php70 php71 php72 php73 php74; do
if which $cmd; then
$cmd -d include_path=.:%{buildroot}%{_datadir}/php:%{_datadir}/php \
%{_bindir}/phpspec run --format pretty --verbose --no-ansi || ret=1
@@ -136,6 +136,12 @@ exit $ret
%changelog
+* Thu Jun 13 2019 Remi Collet <remi@remirepo.net> - 1.8.1-1
+- update to 1.8.1
+
+* Thu Dec 6 2018 Remi Collet <remi@remirepo.net> - 1.8.0-2
+- cleanup for EL-8
+
* Mon Aug 20 2018 Remi Collet <remi@remirepo.net> - 1.8.0-1
- update to 1.8.0