summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-09-27 16:31:47 +0200
committerRemi Collet <remi@php.net>2023-09-27 16:31:47 +0200
commit4d7b60e3b9e53dca81e69b3db26f4f88f3bb3e8f (patch)
tree13e23f0574a69909fd409c0b4afb9895e94f1b69
parent19bceb69709724890c928fce2bd7ed7c484d484b (diff)
disable phpspec tests
-rw-r--r--php-phpspec-prophecy.spec13
1 files changed, 11 insertions, 2 deletions
diff --git a/php-phpspec-prophecy.spec b/php-phpspec-prophecy.spec
index 80181d0..bb0a5fc 100644
--- a/php-phpspec-prophecy.spec
+++ b/php-phpspec-prophecy.spec
@@ -12,10 +12,11 @@
%global gh_project prophecy
%bcond_without tests
+%bcond_with phpspec
Name: php-phpspec-prophecy
Version: 1.17.0
-Release: 2%{?dist}
+Release: 4%{?dist}
Summary: Highly opinionated mocking framework for PHP
License: MIT
@@ -43,7 +44,9 @@ BuildRequires: php-doctrine-instantiator >= 1.2
# "phpspec/phpspec": "^6.0 | ^7.0"
# "phpstan/phpstan": "^1.9",
# "phpunit/phpunit": "^8.0 || ^9.0"
+%if %{with phpspec}
BuildRequires: php-composer(phpspec/phpspec) >= 6.0
+%endif
%global phpunit %{_bindir}/phpunit9
BuildRequires: %{phpunit}
%endif
@@ -145,17 +148,20 @@ EOF
: check autoloader
php %{buildroot}%{_datadir}/php/Prophecy/autoload.php
+%if %{with phpspec}
: check phpspec
phpspec --version
+%endif
ret=0
# ignore it_can_not_double_an_enum on all version. Not ready
for cmdarg in "php %{phpunit}" php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
+%if %{with phpspec}
$1 -d auto_prepend_file=vendor/autoload.php \
%{_bindir}/phpspec run --format pretty --verbose --no-ansi || ret=1
-
+%endif
$1 -d auto_prepend_file=vendor/autoload.php \
${2:-%{_bindir}/phpunit9} \
--filter '^((?!(it_can_not_double_an_enum)).)*$' \
@@ -178,6 +184,9 @@ exit $ret
%changelog
+* Wed Sep 27 2023 Remi Collet <remi@remirepo.net> - 1.17.0-4
+- disable phpspec tests
+
* Fri Feb 3 2023 Remi Collet <remi@remirepo.net> - 1.17.0-2
- fix autoloader