summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-29 14:50:18 +0200
committerRemi Collet <remi@remirepo.net>2020-09-29 14:50:18 +0200
commit46b3bc9f90cdad625d652ebb7171ea51dc855bf6 (patch)
treefb340bf0f85c96e1a9019ee60516ac57e0f370e2
parent7eb5acfc65f9aca4068f7e34ca5913793362d427 (diff)
v1.12.1
-rw-r--r--php-phpspec-prophecy.spec27
1 files changed, 23 insertions, 4 deletions
diff --git a/php-phpspec-prophecy.spec b/php-phpspec-prophecy.spec
index da1a7e2..a6574bc 100644
--- a/php-phpspec-prophecy.spec
+++ b/php-phpspec-prophecy.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
%global bootstrap 0
-%global gh_commit 765cd5d5d237525f8bbadaec5dc161c83a369119
+%global gh_commit 8ce87516be71aae9b956f81906aaf0338e0d8a2d
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project prophecy
@@ -19,8 +19,8 @@
%endif
Name: php-phpspec-prophecy
-Version: 1.12.0
-Release: 2%{?dist}
+Version: 1.12.1
+Release: 1%{?dist}
Summary: Highly opinionated mocking framework for PHP
License: MIT
@@ -100,9 +100,25 @@ phpab --template fedora --output src/Prophecy/autoload.php src
cat << 'EOF' | tee -a src/Prophecy/autoload.php
\Fedora\Autoloader\Dependencies::required([
+ '%{_datadir}/php/Doctrine/Instantiator/autoload.php',
'%{_datadir}/php/phpDocumentor/Reflection/DocBlock5/autoload.php',
]);
-/* Comparator and RecursionContext pulled by phpspec or phpunit */
+if (!class_exists('SebastianBergmann\\Comparator\\Comparator')) { // v2 from phpunit, v1 from phpspec
+ \Fedora\Autoloader\Dependencies::required([
+ [
+ '%{_datadir}/php/SebastianBergmann/Comparator4/autoload.php',
+ '%{_datadir}/php/SebastianBergmann/Comparator3/autoload.php',
+ ],
+ ]);
+}
+if (!class_exists('SebastianBergmann\\RecursionContext\\Context')) { // v2 from phpunit, v1 from phpspec
+ \Fedora\Autoloader\Dependencies::required([
+ [
+ '%{_datadir}/php/SebastianBergmann/RecursionContext4/autoload.php',
+ '%{_datadir}/php/SebastianBergmann/RecursionContext3/autoload.php',
+ ],
+ ]);
+}
EOF
@@ -153,6 +169,9 @@ exit $ret
%changelog
+* Tue Sep 29 2020 Remi Collet <remi@remirepo.net> - 1.12.1-1
+- update to 1.12.1
+
* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 1.12.0-2
- switch to classmap autoloader