summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-10 13:41:14 +0200
committerRemi Collet <remi@remirepo.net>2021-09-10 13:41:14 +0200
commit034859db93bed01e783e2de83648cc7e95e079d7 (patch)
tree14cf401fc191168daa46d515b0e04886127076bf
parentf20ae8ef89028f9b118cad4b25b341ce5d3ce5d6 (diff)
update to 1.14.0HEADmaster
-rw-r--r--composer.json6
-rw-r--r--php-phpspec-prophecy.spec22
2 files changed, 15 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index de6b7c2..129a4cf 100644
--- a/composer.json
+++ b/composer.json
@@ -18,7 +18,7 @@
],
"require": {
- "php": "^7.2 || ~8.0, <8.1",
+ "php": "^7.2 || ~8.0, <8.2",
"phpdocumentor/reflection-docblock": "^5.2",
"sebastian/comparator": "^3.0 || ^4.0",
"doctrine/instantiator": "^1.2",
@@ -26,7 +26,7 @@
},
"require-dev": {
- "phpspec/phpspec": "^6.0",
+ "phpspec/phpspec": "^6.0 || ^7.0",
"phpunit/phpunit": "^8.0 || ^9.0"
},
@@ -44,7 +44,7 @@
"extra": {
"branch-alias": {
- "dev-master": "1.11.x-dev"
+ "dev-master": "1.x-dev"
}
}
}
diff --git a/php-phpspec-prophecy.spec b/php-phpspec-prophecy.spec
index 3df1802..1c83f6f 100644
--- a/php-phpspec-prophecy.spec
+++ b/php-phpspec-prophecy.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit be1996ed8adc35c3fd795488a653f4b518be70ea
+%global gh_commit d86dfc2e2a3cd366cee475e52c6bb3bbc371aa0e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project prophecy
@@ -14,7 +14,7 @@
%bcond_without tests
Name: php-phpspec-prophecy
-Version: 1.13.0
+Version: 1.14.0
Release: 1%{?dist}
Summary: Highly opinionated mocking framework for PHP
@@ -40,21 +40,17 @@ BuildRequires: php-sebastian-recursion-context3
BuildRequires: php-doctrine-instantiator >= 1.2
%endif
# from composer.json, "require-dev": {
-# "phpspec/phpspec": "^6.0"
+# "phpspec/phpspec": "^6.0 | ^7.0"
# "phpunit/phpunit": "^8.0 || ^9.0"
BuildRequires: php-composer(phpspec/phpspec) >= 6.0
-%if 0%{?fedora} >= 32 || 0%{?rhel} >=9
%global phpunit %{_bindir}/phpunit9
-%else
-%global phpunit %{_bindir}/phpunit8
-%endif
BuildRequires: %{phpunit}
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel
# from composer.json, "requires": {
-# "php": "^7.2 || ~8.0, <8.1",
+# "php": "^7.2 || ~8.0, <8.2",
# "phpdocumentor/reflection-docblock": "^5.2",
# "sebastian/comparator": "^3.0|^4.0",
# "doctrine/instantiator": "^1.2",
@@ -144,14 +140,17 @@ php %{buildroot}%{_datadir}/php/Prophecy/autoload.php
phpspec --version
ret=0
-for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+# ignore it_can_not_double_an_enum on all version. Not ready
+for cmdarg in "php %{phpunit}" php73 php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 -d auto_prepend_file=vendor/autoload.php \
%{_bindir}/phpspec run --format pretty --verbose --no-ansi || ret=1
$1 -d auto_prepend_file=vendor/autoload.php \
- ${2:-%{_bindir}/phpunit9}|| ret=1
+ ${2:-%{_bindir}/phpunit9} \
+ --filter '^((?!(it_can_not_double_an_enum)).)*$' \
+ || ret=1
fi
done
exit $ret
@@ -170,6 +169,9 @@ exit $ret
%changelog
+* Fri Sep 10 2021 Remi Collet <remi@remirepo.net> - 1.14.0-1
+- update to 1.14.0
+
* Thu Mar 18 2021 Remi Collet <remi@remirepo.net> - 1.13.0-1
- update to 1.13.0