summaryrefslogtreecommitdiffstats
path: root/php-phpspec-prophecy-phpunit.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-04-19 12:10:44 +0200
committerRemi Collet <remi@php.net>2023-04-19 12:10:44 +0200
commitfd55ed966d69e216ec4860d9f95f4581d1218a12 (patch)
treeb3f2146893d9da09781b9e578b4a764854bdeb9d /php-phpspec-prophecy-phpunit.spec
parente8a9c7b5591be18242fa38f1b160d3293412d744 (diff)
update to 2.0.2
Diffstat (limited to 'php-phpspec-prophecy-phpunit.spec')
-rw-r--r--php-phpspec-prophecy-phpunit.spec16
1 files changed, 11 insertions, 5 deletions
diff --git a/php-phpspec-prophecy-phpunit.spec b/php-phpspec-prophecy-phpunit.spec
index da73b15..9ed8f00 100644
--- a/php-phpspec-prophecy-phpunit.spec
+++ b/php-phpspec-prophecy-phpunit.spec
@@ -1,7 +1,7 @@
# remirepo/fedora spec file for php-phpspec-prophecy-phpunit
#
-# Copyright (c) 2020 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2020-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -9,13 +9,13 @@
%bcond_without tests
-%global gh_commit 2d7a9df55f257d2cba9b1d0c0963a54960657177
+%global gh_commit 9f26c224a2fa335f33e6666cc078fbf388255e87
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpspec
%global gh_project prophecy-phpunit
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.0.1
+Version: 2.0.2
Release: 1%{?dist}
Summary: Integrating the Prophecy mocking library in PHPUnit test cases
@@ -94,15 +94,18 @@ phpab --output vendor/autoload.php fixtures tests
cat << 'EOF' | tee -a vendor/autoload.php
require_once '%{buildroot}%{_datadir}/php/Prophecy/PhpUnit/autoload.php';
+require_once '%{_datadir}/php/PHPUnit9/autoload.php';
EOF
: check autoloader
php %{buildroot}%{_datadir}/php/Prophecy/PhpUnit/autoload.php
+: Fix expecteed path
+sed -e 's:src/::' -i tests/MockFailure.phpt
: upstream test suite
ret=0
-for cmd in php php73 php74 php80; do
+for cmd in php php80 php81 php82; do
if which $cmd; then
$cmd -d auto_prepend_file=vendor/autoload.php \
%{_bindir}/phpunit9 || ret=1
@@ -124,5 +127,8 @@ exit $ret
%changelog
+* Wed Apr 19 2023 Remi Collet <remi@remirepo.net> - 2.0.2-1
+- update to 2.0.2
+
* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 2.0.1-1
- initial package