summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-09-28 16:54:04 +0200
committerRemi Collet <remi@remirepo.net>2020-09-28 16:54:04 +0200
commitc52d90d1c5a78b2c37c0e1bd694cf2b6dc3ab283 (patch)
tree0410107789a8b873f5aecbfc7f395752f032e70b
new package
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-phpspec-prophecy-phpunit.spec128
4 files changed, 169 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..87d223d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-phpspec-prophecy-phpunit.spec b/php-phpspec-prophecy-phpunit.spec
new file mode 100644
index 0000000..2b76fac
--- /dev/null
+++ b/php-phpspec-prophecy-phpunit.spec
@@ -0,0 +1,128 @@
+# remirepo/fedora spec file for php-phpspec-prophecy-phpunit
+#
+# Copyright (c) 2020 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+%bcond_without tests
+
+%global gh_commit 2d7a9df55f257d2cba9b1d0c0963a54960657177
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner phpspec
+%global gh_project prophecy-phpunit
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 2.0.1
+Release: 1%{?dist}
+Summary: Integrating the Prophecy mocking library in PHPUnit test cases
+
+License: MIT
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source2: makesrc.sh
+
+BuildArch: noarch
+BuildRequires: php(language) >= 7.3
+%if %{with tests}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(phpspec/prophecy) >= 1.3 with php-composer(phpspec/prophecy) < 2)
+# remirepo:3
+%else
+BuildRequires: php-phpspec-prophecy >= 1.3
+%endif
+BuildRequires: phpunit9 >= 9.1
+%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel
+
+# from composer.json, "requires": {
+# "php": "^7.3 || ^8",
+# "phpspec/prophecy": "^1.3",
+# "phpunit/phpunit":"^9.1"
+Requires: php(language) >= 7.3
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(phpspec/prophecy) >= 1.3 with php-composer(phpspec/prophecy) < 2)
+# remirepo:3
+%else
+Requires: php-phpspec-prophecy >= 1.3
+%endif
+Requires: phpunit9 >= 9.1
+# From phpcompatinfo report for version 2.0.1
+#none
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Prophecy PhpUnit integrates the Prophecy mocking library with PHPUnit
+to provide an easier mocking in your testsuite.
+
+Autoloader: %{_datadir}/php/Prophecy/PhpUnit/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+phpab --template fedora --output src/autoload.php src
+cat << 'EOF' | tee -a src/autoload.php
+
+\Fedora\Autoloader\Dependencies::required([
+ '%{_datadir}/php/Prophecy/autoload.php',
+]);
+EOF
+
+
+%install
+mkdir -p %{buildroot}%{_datadir}/php/Prophecy/PhpUnit
+cp -pr src/* %{buildroot}%{_datadir}/php/Prophecy/PhpUnit/
+
+
+%check
+%if %{with tests}
+: Dev autoloader
+mkdir vendor
+phpab --output vendor/autoload.php fixtures tests
+
+cat << 'EOF' | tee -a vendor/autoload.php
+require_once '%{buildroot}%{_datadir}/php/Prophecy/PhpUnit/autoload.php';
+EOF
+
+: check autoloader
+php %{buildroot}%{_datadir}/php/Prophecy/PhpUnit/autoload.php
+
+
+: upstream test suite
+ret=0
+for cmd in php php73 php74 php80; do
+ if which $cmd; then
+ $cmd -d auto_prepend_file=vendor/autoload.php \
+ %{_bindir}/phpunit9 || ret=1
+ fi
+done
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+# remirepo:1
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%{_datadir}/php/Prophecy/PhpUnit
+
+
+%changelog
+* Mon Sep 28 2020 Remi Collet <remi@remirepo.net> - 1.12.0-1
+- initial package