summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-12 11:17:08 +0200
committerRemi Collet <remi@php.net>2022-09-12 11:17:08 +0200
commit483fe48be5614e0a91bd2f6b4c00983e01a52a0a (patch)
tree1cd3448e300cbd4f67c44ea6db5cb87885fa36b7
parent441c4ebef4d964718fa05d37ae3b19d03ad95ae2 (diff)
update to 3.0.16
-rw-r--r--composer.json3
-rw-r--r--php-phpseclib3.spec10
2 files changed, 8 insertions, 5 deletions
diff --git a/composer.json b/composer.json
index 0f40d7c..5052d5f 100644
--- a/composer.json
+++ b/composer.json
@@ -62,7 +62,8 @@
"ext-libsodium": "SSH2/SFTP can make use of some algorithms provided by the libsodium-php extension.",
"ext-openssl": "Install the OpenSSL extension in order to speed up a wide variety of cryptographic operations.",
"ext-mcrypt": "Install the Mcrypt extension in order to speed up a few other cryptographic operations.",
- "ext-gmp": "Install the GMP (GNU Multiple Precision) extension in order to speed up arbitrary precision integer arithmetic operations."
+ "ext-gmp": "Install the GMP (GNU Multiple Precision) extension in order to speed up arbitrary precision integer arithmetic operations.",
+ "ext-dom": "Install the DOM extension to load XML formatted public keys."
},
"autoload": {
"files": [
diff --git a/php-phpseclib3.spec b/php-phpseclib3.spec
index ea99ba6..33e5f2c 100644
--- a/php-phpseclib3.spec
+++ b/php-phpseclib3.spec
@@ -3,14 +3,14 @@
%global github_owner phpseclib
%global github_name phpseclib
-%global github_commit 2f0b7af658cbea265cbb4a791d6c29a6613f98ef
+%global github_commit 7181378909ed8890be4db53d289faac5b77f8b05
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global major 3
%bcond_without tests
Name: php-%{composer_vendor}%{major}
-Version: 3.0.14
+Version: 3.0.16
Release: 1%{?dist}
Summary: PHP Secure Communications Library
License: MIT
@@ -118,9 +118,8 @@ php tests/make_compatible_with_new_phpunit_versions.php
# from travis/run-phpunit.sh
# testAuthorityInfoAccess fails without internet access
# testCurveExistance as we remove some files
-# TODO php 8.1
ret=0
-for cmd in "php %{phpunit}" php74 php80 php81; do
+for cmd in "php %{phpunit}" php74 php80 php81 php82; do
if which $cmd; then
set $cmd
$1 -d memory_limit=1G ${2:-%{_bindir}/phpunit9} \
@@ -140,6 +139,9 @@ exit $ret
%changelog
+* Mon Sep 12 2022 Remi Collet <remi@remirepo.net> - 3.0.16-1
+- update to 3.0.16
+
* Mon Apr 4 2022 Remi Collet <remi@remirepo.net> - 3.0.14-1
- update to 3.0.14