summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-phpseclib.spec15
1 files changed, 12 insertions, 3 deletions
diff --git a/php-phpseclib.spec b/php-phpseclib.spec
index 4d00b89..652a95e 100644
--- a/php-phpseclib.spec
+++ b/php-phpseclib.spec
@@ -73,11 +73,20 @@ cp -pr %{composer_vendor} %{buildroot}%{_datadir}/php
%{_bindir}/phpab --output tests/bootstrap.php tests
echo 'require "%{buildroot}%{_datadir}/php/%{composer_vendor}/autoload.php";' >> tests/bootstrap.php
-%{_bindir}/phpunit
-
+ret=0
+run=0
+if which php56; then
+ php56 %{_bindir}/phpunit || ret=1
+ run=1
+fi
if which php70; then
- php70 %{_bindir}/phpunit
+ php70 %{_bindir}/phpunit || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
+%{_bindir}/phpunit --verbose
fi
+exit $ret
%endif
%clean