summaryrefslogtreecommitdiffstats
path: root/php-phpseclib.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-04-16 09:09:24 +0200
committerRemi Collet <remi@remirepo.net>2018-04-16 09:09:24 +0200
commit732fdb29153702f65a061688863ceb0739e3e082 (patch)
treec2120dcd0cb280ad8c71d06afa4882c84efe1bef /php-phpseclib.spec
parentf8078a4b6df7f2a4eed980423eac105622b7bd1f (diff)
v2.0.11
Diffstat (limited to 'php-phpseclib.spec')
-rw-r--r--php-phpseclib.spec37
1 files changed, 23 insertions, 14 deletions
diff --git a/php-phpseclib.spec b/php-phpseclib.spec
index cfeece7..5d06f3f 100644
--- a/php-phpseclib.spec
+++ b/php-phpseclib.spec
@@ -3,12 +3,12 @@
%global github_owner phpseclib
%global github_name phpseclib
-%global github_commit d305b780829ea4252ed9400b3f5937c2c99b51d4
+%global github_commit 7053f06f91b3de78e143d430e55a8f7889efc08b
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global with_tests 0%{!?_without_tests:1}
Name: php-%{composer_vendor}
-Version: 2.0.10
+Version: 2.0.11
Release: 1%{?dist}
Summary: PHP Secure Communications Library
License: MIT
@@ -78,23 +78,26 @@ cp -pr %{composer_vendor} %{buildroot}%{_datadir}/php
%check
%{_bindir}/phpab --output tests/bootstrap.php tests
cat << 'EOF' | tee -a tests/bootstrap.php
+if (class_exists("PHPUnit_Framework_TestCase") && !class_exists("PHPUnit\\Framework\\TestCase")) {
+ class_alias("PHPUnit_Framework_TestCase", "PHPUnit\\Framework\\TestCase");
+}
require "%{buildroot}%{_datadir}/php/%{composer_vendor}/autoload.php";
date_default_timezone_set('UTC');
EOF
-if php %{phpunit} --atleast-version 4.8.35; then
- ret=0
- for cmd in "php %{phpunit}" php70 php71 php72; do
- if which $cmd; then
- set $cmd
- $1 -d memory_limit=1G ${2:-%{_bindir}/phpunit6} --verbose || ret=1
- fi
- done
- exit $ret
-else
- : Skip test as PHPUnit is too old
-fi
+ret=0
+for cmd in "php %{phpunit}" php70 php71 php72; do
+ if which $cmd; then
+ set $cmd
+ $1 -d memory_limit=1G ${2:-%{_bindir}/phpunit6} \
+%if 0%{?rhel} > 0 && 0%{?rhel} < 8
+ --filter '^((?!(testAuthorityInfoAccess)).)*$' \
+%endif
+ --verbose || ret=1
+ fi
+done
+exit $ret
%endif
@@ -106,6 +109,12 @@ fi
%changelog
+* Mon Apr 16 2018 Remi Collet <remi@remirepo.net> - 2.0.11-1
+- update to 2.0.11
+
+* Tue Feb 20 2018 Remi Collet <remi@remirepo.net> - 2.0.10-2
+- allow to run with old PHPUnit
+
* Tue Feb 20 2018 Remi Collet <remi@remirepo.net> - 2.0.10-1
- Update to 2.0.10
- skip tests with PHPUnit < 4.8.35 (EPEL-6)