summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-07 08:07:47 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-07 08:07:47 +0200
commite099e914a3b53195ac4aafd02bc668b147171acc (patch)
tree3596badad16c73591d0af00f2f2f9beb5685d1f9
parentd8ead50fcbc501e54bc5003bdf67b1e87e23e080 (diff)
php-phpseclib: 2.0.2
-rw-r--r--composer.json76
-rwxr-xr-xmakesrc.sh2
-rw-r--r--php-phpseclib-autoload.php5
-rw-r--r--php-phpseclib.spec10
4 files changed, 89 insertions, 4 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..4b84b11
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,76 @@
+{
+ "name": "phpseclib/phpseclib",
+ "type": "library",
+ "description": "PHP Secure Communications Library - Pure-PHP implementations of RSA, AES, SSH2, SFTP, X.509 etc.",
+ "keywords": [
+ "security",
+ "crypto",
+ "cryptography",
+ "encryption",
+ "signature",
+ "signing",
+ "rsa",
+ "aes",
+ "blowfish",
+ "twofish",
+ "ssh",
+ "sftp",
+ "x509",
+ "x.509",
+ "asn1",
+ "asn.1",
+ "BigInteger"
+ ],
+ "homepage": "http://phpseclib.sourceforge.net",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Jim Wigginton",
+ "email": "terrafrost@php.net",
+ "role": "Lead Developer"
+ },
+ {
+ "name": "Patrick Monnerat",
+ "email": "pm@datasphere.ch",
+ "role": "Developer"
+ },
+ {
+ "name": "Andreas Fischer",
+ "email": "bantu@phpbb.com",
+ "role": "Developer"
+ },
+ {
+ "name": "Hans-Jürgen Petrich",
+ "email": "petrich@tronic-media.com",
+ "role": "Developer"
+ },
+ {
+ "name": "Graham Campbell",
+ "email": "graham@alt-three.com",
+ "role": "Developer"
+ }
+ ],
+ "require": {
+ "php": ">=5.3.3"
+ },
+ "require-dev": {
+ "phing/phing": "~2.7",
+ "phpunit/phpunit": "~4.0",
+ "sami/sami": "~2.0",
+ "squizlabs/php_codesniffer": "~2.0"
+ },
+ "suggest": {
+ "ext-libsodium": "SSH2/SFTP can make use of some algorithms provided by the libsodium-php extension.",
+ "ext-openssl": "Install the OpenSSL extension in order to speed up a wide variety of cryptographic operations.",
+ "ext-mcrypt": "Install the Mcrypt extension in order to speed up a few other cryptographic operations.",
+ "ext-gmp": "Install the GMP (GNU Multiple Precision) extension in order to speed up arbitrary precision integer arithmetic operations."
+ },
+ "autoload": {
+ "files": [
+ "phpseclib/bootstrap.php"
+ ],
+ "psr-4": {
+ "phpseclib\\": "phpseclib/"
+ }
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
index 816b3f7..4abe187 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -16,7 +16,7 @@ git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
echo "Getting commit..."
pushd $PROJECT-$COMMIT
git checkout $COMMIT
-cp composer.json ../composer-$VERSION.json
+cp composer.json ../composer.json
popd
echo "Archiving..."
diff --git a/php-phpseclib-autoload.php b/php-phpseclib-autoload.php
index b195e0d..4367aa0 100644
--- a/php-phpseclib-autoload.php
+++ b/php-phpseclib-autoload.php
@@ -14,6 +14,11 @@ if (!isset($fedoraClassLoader) || !($fedoraClassLoader instanceof \Symfony\Compo
$fedoraClassLoader = new \Symfony\Component\ClassLoader\ClassLoader();
$fedoraClassLoader->register();
}
+
+// composer.json: "autoload": { "files": [ "phpseclib/bootstrap.php" ], "psr-4": { "phpseclib\\": "phpseclib/" }
+require_once __DIR__ . '/bootstrap.php';
+
$fedoraClassLoader->addPrefixes(array(
'phpseclib' => dirname(__DIR__),
));
+
diff --git a/php-phpseclib.spec b/php-phpseclib.spec
index 0673d0f..6aca3d2 100644
--- a/php-phpseclib.spec
+++ b/php-phpseclib.spec
@@ -3,7 +3,7 @@
%global github_owner phpseclib
%global github_name phpseclib
-%global github_commit ba6fb78f727cd09f2a649113b95468019e490585
+%global github_commit 3d265f7c079f5b37d33475f996d7a383c5fc8aeb
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%if 0%{?rhel} == 5
%global with_tests 0%{?_with_tests:1}
@@ -12,7 +12,7 @@
%endif
Name: php-%{composer_vendor}
-Version: 2.0.1
+Version: 2.0.2
Release: 1%{?dist}
Summary: PHP Secure Communications Library
@@ -90,9 +90,13 @@ rm -rf %{buildroot}
%{!?_licensedir:%global license %%doc}
%license LICENSE
+
%changelog
+* Tue Jun 7 2016 Remi Collet <remi@fedoraproject.org> - 2.0.2-1
+- update to 2.0.2
+
* Tue Jan 19 2016 Remi Collet <remi@fedoraproject.org> - 2.0.1-1
-- update to 1.0.1
+- update to 2.0.1
- sources from git snapshot for tests
- run test suite with both PHP 5 and 7 when available