summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-09-16 08:00:11 +0200
committerRemi Collet <remi@remirepo.net>2019-09-16 08:00:11 +0200
commit1a320f952851a521262e63d88e783cb20981a975 (patch)
tree306b0320c66130a321389bf12252ad1f3fc32e73
parentc8542277e7fc375d1c1dfda3dd2435be01178bd8 (diff)
v1.0.17
-rw-r--r--php-phpseclib-Net-SSH2-Crypt_Blowfish_conflict.patch39
-rw-r--r--php-phpseclib-net-ssh2.spec5
2 files changed, 10 insertions, 34 deletions
diff --git a/php-phpseclib-Net-SSH2-Crypt_Blowfish_conflict.patch b/php-phpseclib-Net-SSH2-Crypt_Blowfish_conflict.patch
index a8d9776..99dff49 100644
--- a/php-phpseclib-Net-SSH2-Crypt_Blowfish_conflict.patch
+++ b/php-phpseclib-Net-SSH2-Crypt_Blowfish_conflict.patch
@@ -1,46 +1,19 @@
-diff -up Net_SSH2-0.3.7/SSH2.php.orig Net_SSH2-0.3.7/SSH2.php
---- Net_SSH2-0.3.7/SSH2.php.orig 2014-07-07 17:36:06.047391436 +0200
-+++ Net_SSH2-0.3.7/SSH2.php 2014-07-07 17:38:56.852300410 +0200
-@@ -1147,7 +1147,7 @@ class Net_SSH2
- array('twofish128-ctr', 'twofish192-ctr', 'twofish256-ctr', 'twofish128-cbc', 'twofish192-cbc', 'twofish256-cbc', 'twofish-cbc')
- );
- }
-- if (phpseclib_resolve_include_path('Crypt/Blowfish.php') === false) {
-+ if (phpseclib_resolve_include_path('Crypt/Blowfish-phpseclib.php') === false) {
- $encryption_algorithms = array_diff(
- $encryption_algorithms,
- array('blowfish-ctr', 'blowfish-cbc')
-@@ -1515,14 +1515,14 @@ class Net_SSH2
+diff -up Net_SSH2-1.0.17/SSH2.php.old Net_SSH2-1.0.17/SSH2.php
+--- Net_SSH2-1.0.17/SSH2.php.old 2019-09-16 07:59:20.346172698 +0200
++++ Net_SSH2-1.0.17/SSH2.php 2019-09-16 07:59:00.696254003 +0200
+@@ -2035,13 +2035,13 @@ class Net_SSH2
break;
case 'blowfish-cbc':
if (!class_exists('Crypt_Blowfish')) {
- include_once 'Crypt/Blowfish.php';
+ include_once 'Crypt/Blowfish-phpseclib.php';
}
- $this->encrypt = new Crypt_Blowfish();
- $this->encrypt_block_size = 8;
+ return new Crypt_Blowfish();
break;
case 'blowfish-ctr':
if (!class_exists('Crypt_Blowfish')) {
- include_once 'Crypt/Blowfish.php';
+ include_once 'Crypt/Blowfish-phpseclib.php';
}
- $this->encrypt = new Crypt_Blowfish(CRYPT_BLOWFISH_MODE_CTR);
- $this->encrypt_block_size = 8;
-@@ -1591,14 +1591,14 @@ class Net_SSH2
+ return new Crypt_Blowfish(CRYPT_BLOWFISH_MODE_CTR);
break;
- case 'blowfish-cbc':
- if (!class_exists('Crypt_Blowfish')) {
-- include_once 'Crypt/Blowfish.php';
-+ include_once 'Crypt/Blowfish-phpseclib.php';
- }
- $this->decrypt = new Crypt_Blowfish();
- $this->decrypt_block_size = 8;
- break;
- case 'blowfish-ctr':
- if (!class_exists('Crypt_Blowfish')) {
-- include_once 'Crypt/Blowfish.php';
-+ include_once 'Crypt/Blowfish-phpseclib.php';
- }
- $this->decrypt = new Crypt_Blowfish(CRYPT_BLOWFISH_MODE_CTR);
- $this->decrypt_block_size = 8;
diff --git a/php-phpseclib-net-ssh2.spec b/php-phpseclib-net-ssh2.spec
index d7b12d7..e6e4b31 100644
--- a/php-phpseclib-net-ssh2.spec
+++ b/php-phpseclib-net-ssh2.spec
@@ -11,7 +11,7 @@
%global pear_name Net_SSH2
Name: php-phpseclib-net-ssh2
-Version: 1.0.16
+Version: 1.0.17
Release: 1%{?dist}
Summary: Pure-PHP implementation of SSHv2
@@ -94,6 +94,9 @@ fi
%changelog
+* Mon Sep 16 2019 Remi Collet <remi@remirepo.net> - 1.0.17-1
+- update to 1.0.17
+
* Thu Jun 13 2019 Remi Collet <remi@remirepo.net> - 1.0.16-1
- update to 1.0.16