summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-01-15 07:23:20 +0100
committerRemi Collet <fedora@famillecollet.com>2014-01-15 07:23:20 +0100
commit875fff86cb08397f8c34fbf4e538594e611bb243 (patch)
treee06d93d3feda1a0c5ef111652218bef6f5358b28
parentbe28ec9c98732b6a46ec6ae2a3a743205fed6494 (diff)
php-phpseclib-crypt-twofish: backport
-rw-r--r--Makefile4
-rw-r--r--php-phpseclib-crypt-twofish.spec12
2 files changed, 14 insertions, 2 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-phpseclib-crypt-twofish.spec b/php-phpseclib-crypt-twofish.spec
index a867754..c5beb77 100644
--- a/php-phpseclib-crypt-twofish.spec
+++ b/php-phpseclib-crypt-twofish.spec
@@ -12,6 +12,7 @@ License: MIT
URL: http://phpseclib.sourceforge.net/
Source0: http://phpseclib.sourceforge.net/get/%{pear_name}-%{version}.tgz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear(PEAR)
@@ -39,6 +40,7 @@ cd %{pear_name}-%{version}
%install
+rm -rf $RPM_BUILD_ROOT
cd %{pear_name}-%{version}
%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
@@ -50,6 +52,10 @@ mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+
%post
%{__pear} install --nodeps --soft --force --register-only \
%{pear_xmldir}/%{name}.xml >/dev/null || :
@@ -62,13 +68,15 @@ fi
%files
+%defattr(-, root, root, -)
%{pear_xmldir}/%{name}.xml
-# Expand this as needed to avoid owning dirs owned by our dependencies
-# and to avoid unowned dirs
%{pear_phpdir}/Crypt/Twofish.php
%changelog
+* Wed Jan 15 2014 Remi Collet <rpms@famillecollet.com> - 0.3.5-3
+- backport for remi repo
+
* Thu Jan 09 2014 Adam Williamson <awilliam@redhat.com> - 0.3.5-3
- requires crypt-hash, drop ownership of Crypt dir