summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-01-24 07:53:51 +0100
committerRemi Collet <fedora@famillecollet.com>2014-01-24 07:53:51 +0100
commit48cc898254b2fe5047dcf3791cb09fb07297f616 (patch)
treed0222a75b1e68cc5627967d7f853daf4563b1161
php-phpseclib-crypt-tripledes: import from rawhide
-rw-r--r--php-phpseclib-crypt-tripledes.spec80
1 files changed, 80 insertions, 0 deletions
diff --git a/php-phpseclib-crypt-tripledes.spec b/php-phpseclib-crypt-tripledes.spec
new file mode 100644
index 0000000..1645435
--- /dev/null
+++ b/php-phpseclib-crypt-tripledes.spec
@@ -0,0 +1,80 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Crypt_TripleDES
+
+Name: php-phpseclib-crypt-tripledes
+Version: 0.3.5
+Release: 3%{?dist}
+Summary: Pure-PHP implementation of Triple DES
+
+Group: Development/Libraries
+License: MIT
+URL: http://phpseclib.sourceforge.net/
+Source0: http://phpseclib.sourceforge.net/get/%{pear_name}-%{version}.tgz
+
+BuildArch: noarch
+BuildRequires: php-pear(PEAR)
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php-pear(PEAR)
+Requires: php-pear(phpseclib.sourceforge.net/Crypt_DES) >= 0.3.0
+Requires: php-pear(phpseclib.sourceforge.net/Crypt_Hash)
+Requires: php-pear(PEAR) >= 1.4.0
+Provides: php-pear(phpseclib.sourceforge.net/Crypt_TripleDES) = %{version}
+BuildRequires: php-channel(phpseclib.sourceforge.net)
+Requires: php-channel(phpseclib.sourceforge.net)
+
+%description
+Uses mcrypt, if available, and an internal implementation, otherwise.
+Operates in the EDE3 mode (encrypt-decrypt-encrypt).
+
+%prep
+%setup -q -c
+mv package.xml %{pear_name}-%{version}/%{name}.xml
+
+cd %{pear_name}-%{version}
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+
+# Clean up unnecessary files
+rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ phpseclib.sourceforge.net/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Crypt/TripleDES.php
+
+
+%changelog
+* Thu Jan 09 2014 Adam Williamson <awilliam@redhat.com> - 0.3.5-3
+- requires crypt-hash
+
+* Sat Jan 4 2014 Adam Williamson <awilliam@redhat.com> - 0.3.5-2
+- various review style cleanups
+
+* Tue Dec 31 2013 Adam Williamson <awilliam@redhat.com> - 0.3.5-1
+- initial package (generated with pear make-rpm-spec)