summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-08-03 10:11:21 +0200
committerRemi Collet <fedora@famillecollet.com>2015-08-03 10:11:21 +0200
commit937a271f08fd01aad71078c5b1133f903561f49e (patch)
tree210729d649d0ebd7df6097e075614f0d72660b42
parent2c89bea7717da30b76850663466daad1b72b772c (diff)
php-phpseclib-crypt-rsa: 1.0.0
-rw-r--r--Crypt_RSA-role.patch12
-rw-r--r--php-phpseclib-crypt-rsa.spec14
2 files changed, 19 insertions, 7 deletions
diff --git a/Crypt_RSA-role.patch b/Crypt_RSA-role.patch
index 93d1ee2..ee1c284 100644
--- a/Crypt_RSA-role.patch
+++ b/Crypt_RSA-role.patch
@@ -1,7 +1,7 @@
-diff -up Crypt_RSA-0.3.8/RSA.php.role Crypt_RSA-0.3.8/RSA.php
---- Crypt_RSA-0.3.8/RSA.php.role 2014-09-13 09:31:03.775079734 +0200
-+++ Crypt_RSA-0.3.8/RSA.php 2014-09-13 09:32:39.595509197 +0200
-@@ -178,7 +178,7 @@ define('CRYPT_RSA_MODE_OPENSSL', 2);
+diff -up Crypt_RSA-1.0.0/RSA.php.role Crypt_RSA-1.0.0/RSA.php
+--- Crypt_RSA-1.0.0/RSA.php.role 2015-08-03 10:04:38.075882028 +0200
++++ Crypt_RSA-1.0.0/RSA.php 2015-08-03 10:07:45.204836674 +0200
+@@ -185,7 +185,7 @@ define('CRYPT_RSA_MODE_OPENSSL', 2);
/**
* Default openSSL configuration file.
*/
@@ -10,7 +10,7 @@ diff -up Crypt_RSA-0.3.8/RSA.php.role Crypt_RSA-0.3.8/RSA.php
/**#@+
* @access public
-@@ -490,7 +490,14 @@ class Crypt_RSA
+@@ -497,7 +497,14 @@ class Crypt_RSA
include_once 'Math/BigInteger.php';
}
@@ -24,5 +24,5 @@ diff -up Crypt_RSA-0.3.8/RSA.php.role Crypt_RSA-0.3.8/RSA.php
+ }
+ $this->configFile = $dir . DIRECTORY_SEPARATOR . CRYPT_RSA_OPENSSL_CONFIG;
- if ( !defined('CRYPT_RSA_MODE') ) {
+ if (!defined('CRYPT_RSA_MODE')) {
switch (true) {
diff --git a/php-phpseclib-crypt-rsa.spec b/php-phpseclib-crypt-rsa.spec
index 775f140..f9adb26 100644
--- a/php-phpseclib-crypt-rsa.spec
+++ b/php-phpseclib-crypt-rsa.spec
@@ -1,8 +1,17 @@
+# remirepo spec file for php-phpseclib-crypt-rsa, from:
+#
+# Fedora spec file for php-phpseclib-crypt-rsa
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name Crypt_RSA
Name: php-phpseclib-crypt-rsa
-Version: 0.3.10
+Version: 1.0.0
Release: 1%{?dist}
Summary: Pure-PHP PKCS#1 (v2.1) compliant implementation of RSA
@@ -91,6 +100,9 @@ fi
%changelog
+* Mon Aug 03 2015 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- Update to 1.0.0
+
* Tue Feb 10 2015 Remi Collet <remi@fedoraproject.org> - 0.3.10-1
- Update to 0.3.10