summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-02-26 18:25:38 +0100
committerRemi Collet <fedora@famillecollet.com>2014-02-26 18:25:38 +0100
commit4d1c2b91643f978bae4768b0c689e50db722fb26 (patch)
treea19596e76e1892673e395a7b975fcd751ca8a037
parentd3b965a9546e6f52b47e30e00be525e18f68939e (diff)
php-phpseclib-*: 0.3.6
-rw-r--r--Crypt_RSA-role.patch26
-rw-r--r--php-phpseclib-crypt-rsa.spec21
2 files changed, 26 insertions, 21 deletions
diff --git a/Crypt_RSA-role.patch b/Crypt_RSA-role.patch
index 079032c..feab1fe 100644
--- a/Crypt_RSA-role.patch
+++ b/Crypt_RSA-role.patch
@@ -1,16 +1,17 @@
---- Crypt_RSA-0.3.5/RSA.php 2014-01-07 11:18:22.000000000 +0100
-+++ Crypt_RSA-0.3.5/RSA.php.fix 2014-01-07 11:18:22.000000000 +0100
-@@ -171,7 +171,7 @@ define('CRYPT_RSA_MODE_OPENSSL', 2);
+diff -up ./Crypt_RSA-0.3.6/RSA.php.orig ./Crypt_RSA-0.3.6/RSA.php
+--- ./Crypt_RSA-0.3.6/RSA.php.orig 2014-02-26 17:57:48.055385477 +0100
++++ ./Crypt_RSA-0.3.6/RSA.php 2014-02-26 17:59:38.974772761 +0100
+@@ -170,7 +170,7 @@ define('CRYPT_RSA_MODE_OPENSSL', 2);
/**
* Default openSSL configuration file.
*/
-define('CRYPT_RSA_OPENSSL_CONFIG', dirname(__FILE__) . '/../openssl.cnf');
+define('CRYPT_RSA_OPENSSL_CONFIG', 'openssl.cnf');
-
/**#@+
-@@ -465,7 +465,14 @@ class Crypt_RSA {
- require_once('Math/BigInteger.php');
+ * @access public
+@@ -464,7 +464,14 @@ class Crypt_RSA
+ include_once 'Math/BigInteger.php';
}
- $this->configFile = CRYPT_RSA_OPENSSL_CONFIG;
@@ -24,14 +25,15 @@
+ $this->configFile = $dir . DIRECTORY_SEPARATOR . CRYPT_RSA_OPENSSL_CONFIG;
if ( !defined('CRYPT_RSA_MODE') ) {
- switch (true) {
---- package.xml 2014-01-07 11:03:40.000000000 +0100
-+++ package.xml.fix 2014-01-07 11:06:12.000000000 +0100
-@@ -23,8 +23,10 @@
- <notes>0.3.5 release</notes>
+ // Math/BigInteger's openssl requirements are a little less stringent than Crypt/RSA's. in particular,
+diff -up ./package.xml.orig ./package.xml
+--- ./package.xml.orig 2014-02-26 17:59:38.974772761 +0100
++++ ./package.xml 2014-02-26 18:00:08.020874166 +0100
+@@ -23,8 +23,10 @@
+ <notes>0.3.6 release</notes>
<contents>
<dir name="/">
-- <file baseinstalldir="Crypt" name="RSA.php" role="php" md5sum="bd0402efcbf7cdeb3e68205c77a88bc0"/>
+- <file baseinstalldir="Crypt" name="RSA.php" role="php" md5sum="158051c445d140e7b4486487307a8f11"/>
- <file baseinstalldir="" name="openssl.cnf" role="php" md5sum="0f1015cb8894127a94a05afa7cc23760"/>
+ <file baseinstalldir="Crypt" name="RSA.php" role="php">
+ <tasks:replace from="@cfg_dir@" to="cfg_dir" type="pear-config" />
diff --git a/php-phpseclib-crypt-rsa.spec b/php-phpseclib-crypt-rsa.spec
index 0672310..b7623ad 100644
--- a/php-phpseclib-crypt-rsa.spec
+++ b/php-phpseclib-crypt-rsa.spec
@@ -1,9 +1,9 @@
-%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name Crypt_RSA
Name: php-phpseclib-crypt-rsa
-Version: 0.3.5
-Release: 3%{?dist}
+Version: 0.3.6
+Release: 1%{?dist}
Summary: Pure-PHP PKCS#1 (v2.1) compliant implementation of RSA
Group: Development/Libraries
@@ -51,20 +51,20 @@ cd %{pear_name}-%{version}
%install
-rm -rf $RPM_BUILD_ROOT
+rm -rf %{buildroot}
cd %{pear_name}-%{version}
-%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%clean
-rm -rf $RPM_BUILD_ROOT
+rm -rf %{buildroot}
%post
@@ -87,6 +87,9 @@ fi
%changelog
+* Wed Feb 26 2014 Remi Collet <remi@fedoraproject.org> - 0.3.6-1
+- Update to 0.3.6
+
* Sat Jan 24 2014 Remi Collet <rpms@famillecollet.com> - 0.3.5-3
- backport for remi repo