summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-01-15 07:18:30 +0100
committerRemi Collet <fedora@famillecollet.com>2014-01-15 07:18:30 +0100
commitf413ec3ee42dbcf4d37465cfab63e037333c7000 (patch)
treea2bb861e19d83e42a401a6e2853a7c7252e59a9d
php-phpseclib-crypt-rijndael: import from rawhide
-rw-r--r--php-phpseclib-crypt-rijndael.spec74
1 files changed, 74 insertions, 0 deletions
diff --git a/php-phpseclib-crypt-rijndael.spec b/php-phpseclib-crypt-rijndael.spec
new file mode 100644
index 0000000..8024848
--- /dev/null
+++ b/php-phpseclib-crypt-rijndael.spec
@@ -0,0 +1,74 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Crypt_Rijndael
+
+Name: php-phpseclib-crypt-rijndael
+Version: 0.3.5
+Release: 2%{?dist}
+Summary: Pure-PHP implementation of Rijndael
+
+Group: Development/Libraries
+License: MIT
+URL: http://phpseclib.sourceforge.net/
+Source0: http://phpseclib.sourceforge.net/get/%{pear_name}-%{version}.tgz
+
+BuildArch: noarch
+BuildRequires: php-pear(PEAR)
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php-pear(PEAR)
+Provides: php-pear(phpseclib.sourceforge.net/Crypt_Rijndael) = %{version}
+BuildRequires: php-channel(phpseclib.sourceforge.net)
+Requires: php-channel(phpseclib.sourceforge.net)
+
+%description
+Does not use mcrypt, even when available, for reasons discussed in
+Rijndael.php.
+
+%prep
+%setup -q -c
+mv package.xml %{pear_name}-%{version}/%{name}.xml
+
+cd %{pear_name}-%{version}
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+
+# Clean up unnecessary files
+rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ phpseclib.sourceforge.net/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Crypt
+
+
+%changelog
+* Sat Jan 4 2014 Adam Williamson <awilliam@redhat.com> - 0.3.5-2
+- various review style cleanups
+
+* Tue Dec 31 2013 Adam Williamson <awilliam@redhat.com> - 0.3.5-1
+- initial package (generated with pear make-rpm-spec)