summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-01-15 07:15:25 +0100
committerRemi Collet <fedora@famillecollet.com>2014-01-15 07:15:25 +0100
commit7e5f1c4a9f6a52e270faeaf059b0c264c076ab6b (patch)
treee28e2912cc85385dde626d52ea8898f63343f736
php-phpseclib-crypt-rc4: import from rawhide
-rw-r--r--php-phpseclib-crypt-rc4.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/php-phpseclib-crypt-rc4.spec b/php-phpseclib-crypt-rc4.spec
new file mode 100644
index 0000000..113bb3b
--- /dev/null
+++ b/php-phpseclib-crypt-rc4.spec
@@ -0,0 +1,75 @@
+%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
+%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%global pear_name Crypt_RC4
+
+Name: php-phpseclib-crypt-rc4
+Version: 0.3.5
+Release: 2%{?dist}
+Summary: Pure-PHP implementation of RC4
+
+Group: Development/Libraries
+License: MIT
+URL: http://phpseclib.sourceforge.net/
+Source0: http://phpseclib.sourceforge.net/get/%{pear_name}-%{version}.tgz
+
+BuildArch: noarch
+BuildRequires: php-pear(PEAR)
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php-pear(PEAR)
+Provides: php-pear(phpseclib.sourceforge.net/Crypt_RC4) = %{version}
+BuildRequires: php-channel(phpseclib.sourceforge.net)
+Requires: php-channel(phpseclib.sourceforge.net)
+
+%description
+Uses mcrypt, if available, and an internal implementation, otherwise.
+
+%prep
+%setup -q -c
+mv package.xml %{pear_name}-%{version}/%{name}.xml
+
+cd %{pear_name}-%{version}
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+
+# Clean up unnecessary files
+rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
+install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ phpseclib.sourceforge.net/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%{pear_xmldir}/%{name}.xml
+# Expand this as needed to avoid owning dirs owned by our dependencies
+# and to avoid unowned dirs
+%{pear_phpdir}/Crypt
+
+
+%changelog
+* Sat Jan 4 2014 Adam Williamson <awilliam@redhat.com> - 0.3.5-2
+- various review style cleanups
+
+* Tue Dec 31 2013 Adam Williamson <awilliam@redhat.com> - 0.3.5-1
+- initial package (generated with pear make-rpm-spec)