summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-07-07 17:06:53 +0200
committerRemi Collet <fedora@famillecollet.com>2014-07-07 17:06:53 +0200
commitaf3d535723a72e3331370f0382a6b7c922376ca1 (patch)
tree8ae2a18473e7a12165b6c6e860cd248527a0d7d9
php-phpseclib-crypt-base: new package
-rw-r--r--Makefile4
-rw-r--r--php-phpseclib-crypt-base.spec82
2 files changed, 86 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-phpseclib-crypt-base.spec b/php-phpseclib-crypt-base.spec
new file mode 100644
index 0000000..543c192
--- /dev/null
+++ b/php-phpseclib-crypt-base.spec
@@ -0,0 +1,82 @@
+%{!?__pear: %global __pear %{_bindir}/pear}
+%global pear_name Crypt_Base
+
+Name: php-phpseclib-crypt-base
+Version: 0.3.7
+Release: 1%{?dist}
+Summary: Base class for symmetric key cryptographic algorithms
+
+Group: Development/Libraries
+License: MIT License
+URL: http://phpseclib.sourceforge.net/
+Source0: http://phpseclib.sourceforge.net/get/%{pear_name}-%{version}.tgz
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildArch: noarch
+BuildRequires: php-pear(PEAR)
+BuildRequires: php-channel(phpseclib.sourceforge.net)
+
+Requires(post): %{__pear}
+Requires(postun): %{__pear}
+Requires: php-pear(PEAR)
+Requires: php-channel(phpseclib.sourceforge.net)
+# optional
+Requires: php-mhash
+Requires: php-mcrypt
+
+Provides: php-pear(phpseclib.sourceforge.net/Crypt_Base) = %{version}
+
+
+%description
+This file is a common dependency required for multiple Crypt_* classes.
+
+
+%prep
+%setup -q -c
+
+cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
+
+
+%build
+cd %{pear_name}-%{version}
+# Empty build section, most likely nothing required.
+
+
+%install
+cd %{pear_name}-%{version}
+rm -rf %{buildroot}
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
+
+# Clean up unnecessary files
+rm -rf %{buildroot}%{pear_metadir}/.??*
+
+# Install XML package description
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%post
+%{__pear} install --nodeps --soft --force --register-only \
+ %{pear_xmldir}/%{name}.xml >/dev/null || :
+
+%postun
+if [ $1 -eq 0 ] ; then
+ %{__pear} uninstall --nodeps --ignore-errors --register-only \
+ phpseclib.sourceforge.net/%{pear_name} >/dev/null || :
+fi
+
+
+%files
+%defattr(-,root,root,-)
+%{pear_xmldir}/%{name}.xml
+%{pear_phpdir}/Crypt
+
+
+%changelog
+* Mon Jul 07 2014 Remi Collet <remi@fedoraproject.org> - 0.3.7-1
+- Initial packaging, version 0.3.7 \ No newline at end of file