summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json21
-rw-r--r--phpMyAdmin.spec43
2 files changed, 35 insertions, 29 deletions
diff --git a/composer.json b/composer.json
index 235c30b..8fb9d67 100644
--- a/composer.json
+++ b/composer.json
@@ -86,7 +86,7 @@
"php-webdriver/webdriver": "^1.11",
"phpmyadmin/coding-standard": "^2.1.1",
"phpstan/extension-installer": "^1.1",
- "phpstan/phpstan": "^1.4.5",
+ "phpstan/phpstan": "^1.4.8",
"phpstan/phpstan-phpunit": "^1.0",
"phpunit/phpunit": "^7.5 || ^8.0 || ^9.0",
"pragmarx/google2fa-qrcode": "^1.0.1",
@@ -94,7 +94,7 @@
"symfony/finder": "^4.4",
"symfony/twig-bridge": "^4.4",
"tecnickcom/tcpdf": "^6.4.4",
- "vimeo/psalm": "^4.19"
+ "vimeo/psalm": "^4.22"
},
"extra": {
"branch-alias": {
@@ -102,19 +102,22 @@
}
},
"scripts": {
- "phpcbf": "phpcbf",
- "phpcs": "phpcs",
- "phpstan": "phpstan analyse",
- "psalm": "psalm",
- "phpunit": "phpunit --color=always",
+ "phpcbf": "@php phpcbf",
+ "phpcs": "@php phpcs",
+ "phpstan": "@php phpstan analyse",
+ "psalm": "@php psalm",
+ "phpunit": "@php phpunit --color=always",
"test": [
"@phpcs",
"@phpstan",
"@psalm",
"@phpunit"
],
- "update:baselines": "phpstan analyse --generate-baseline && psalm --set-baseline=psalm-baseline.xml",
- "twig-lint": "php scripts/console lint:twig templates --ansi --show-deprecations"
+ "update:baselines": [
+ "@php phpstan analyse --generate-baseline",
+ "@php psalm --set-baseline=psalm-baseline.xml"
+ ],
+ "twig-lint": "@php scripts/console lint:twig templates --ansi --show-deprecations"
},
"config":{
"sort-packages": true,
diff --git a/phpMyAdmin.spec b/phpMyAdmin.spec
index d80a5e0..cbcf6b8 100644
--- a/phpMyAdmin.spec
+++ b/phpMyAdmin.spec
@@ -27,12 +27,12 @@
%global with_httpd 0
%endif
-%global upstream_version 5.1.3
+%global upstream_version 5.1.4
#global upstream_prever rc2
Name: phpMyAdmin
Version: %{upstream_version}%{?upstream_prever:~%{upstream_prever}}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: A web interface for MySQL and MariaDB
# MIT (js/jquery/, js/jqplot, js/codemirror/, js/tracekit/)
@@ -185,38 +185,38 @@ Requires: php-code-lts-u2f-php-server >= 1.2
Requires: php-tcpdf-dejavu-sans-fonts >= 6.2
%endif
%else
-Provides: bundled(php-bacon-bacon-qr-code) = 2.0.6
+Provides: bundled(php-bacon-bacon-qr-code) = 2.0.7
Provides: bundled(php-code-lts-u2f-php-server) = v1.2.0
Provides: bundled(php-dasprid-enum) = 1.0.3
Provides: bundled(php-google-recaptcha) = 1.2.4
Provides: bundled(php-nikic-fast-route) = v1.3.0
Provides: bundled(php-paragonie-constant-time-encoding) = v2.5.0
-Provides: bundled(php-phpmyadmin-motranslator) = 5.2.0
+Provides: bundled(php-phpmyadmin-motranslator) = 5.3.0
Provides: bundled(php-phpmyadmin-shapefile) = 2.1
Provides: bundled(php-phpmyadmin-sql-parser) = 5.5.0
Provides: bundled(php-phpmyadmin-twig-i18n-extension) = v3.0.0
-Provides: bundled(php-phpseclib-phpseclib) = 2.0.36
+Provides: bundled(php-phpseclib-phpseclib) = 2.0.37
Provides: bundled(php-pragmarx-google2fa) = 8.0.0
Provides: bundled(php-pragmarx-google2fa-qrcode) = v1.0.3
Provides: bundled(php-psr-cache) = 1.0.1
Provides: bundled(php-psr-container) = 1.0.0
Provides: bundled(php-psr-log) = 1.1.4
-Provides: bundled(php-symfony-cache) = v4.4.37
-Provides: bundled(php-symfony-cache-contracts) = v1.1.11
-Provides: bundled(php-symfony-config) = v4.4.37
-Provides: bundled(php-symfony-dependency-injection) = v4.4.37
-Provides: bundled(php-symfony-expression-language) = v4.4.37
-Provides: bundled(php-symfony-filesystem) = v4.4.37
-Provides: bundled(php-symfony-polyfill-ctype) = v1.24.0
-Provides: bundled(php-symfony-polyfill-mbstring) = v1.24.0
-Provides: bundled(php-symfony-polyfill-php72) = v1.24.0
-Provides: bundled(php-symfony-polyfill-php73) = v1.24.0
-Provides: bundled(php-symfony-polyfill-php80) = v1.24.0
-Provides: bundled(php-symfony-polyfill-php81) = v1.24.0
-Provides: bundled(php-symfony-service-contracts) = v1.1.11
-Provides: bundled(php-symfony-var-exporter) = v4.4.37
+Provides: bundled(php-symfony-cache) = v4.4.41
+Provides: bundled(php-symfony-cache-contracts) = v1.1.12
+Provides: bundled(php-symfony-config) = v4.4.41
+Provides: bundled(php-symfony-dependency-injection) = v4.4.41
+Provides: bundled(php-symfony-expression-language) = v4.4.41
+Provides: bundled(php-symfony-filesystem) = v4.4.39
+Provides: bundled(php-symfony-polyfill-ctype) = v1.25.0
+Provides: bundled(php-symfony-polyfill-mbstring) = v1.25.0
+Provides: bundled(php-symfony-polyfill-php72) = v1.25.0
+Provides: bundled(php-symfony-polyfill-php73) = v1.25.0
+Provides: bundled(php-symfony-polyfill-php80) = v1.25.0
+Provides: bundled(php-symfony-polyfill-php81) = v1.25.0
+Provides: bundled(php-symfony-service-contracts) = v1.1.12
+Provides: bundled(php-symfony-var-exporter) = v4.4.41
Provides: bundled(php-tecnickcom-tcpdf) = 6.4.4
-Provides: bundled(php-twig-twig) = v2.14.11
+Provides: bundled(php-twig-twig) = v2.14.13
Provides: bundled(php-williamdes-mariadb-mysql-kbs) = v1.2.13
Requires: php-dom
Requires: php-intl
@@ -416,6 +416,9 @@ sed -e "/'blowfish_secret'/s/MUSTBECHANGEDONINSTALL/$SECRET/" \
%changelog
+* Thu May 12 2022 Remi Collet <remi@remirepo.net> - 5.1.4-1
+- update to 5.1.4 (2022-05-10, bugfix release)
+
* Fri Feb 11 2022 Remi Collet <remi@remirepo.net> - 5.1.3-2
- update to 5.1.3 (2022-02-10, security and bugfix release)
- always use bundled libraries