summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json4
-rw-r--r--php-phpmyadmin-sql-parser.spec13
2 files changed, 10 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 28cdaed..eb61a92 100644
--- a/composer.json
+++ b/composer.json
@@ -20,8 +20,8 @@
"ext-mbstring": "*"
},
"require-dev": {
- "phpunit/php-code-coverage": "~2.0 || ~3.0",
- "phpunit/phpunit": "~4.8 || ~5.1"
+ "phpunit/php-code-coverage": "*",
+ "phpunit/phpunit": "~4.8 || ~5.7"
},
"conflict": {
"phpmyadmin/motranslator": "<3.0"
diff --git a/php-phpmyadmin-sql-parser.spec b/php-phpmyadmin-sql-parser.spec
index f2ffa73..26d25ab 100644
--- a/php-phpmyadmin-sql-parser.spec
+++ b/php-phpmyadmin-sql-parser.spec
@@ -7,7 +7,7 @@
# Please, preserve the changelog entries
#
-%global gh_commit fc8a6b24f20a6d6d12a647a4d468c25b0d9084ff
+%global gh_commit 10b6f2b274e499d2ad6c069f97ead34db5989b03
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpmyadmin
#global gh_date 20150820
@@ -17,8 +17,8 @@
%global ns_project SqlParser
Name: php-%{gh_owner}-%{gh_project}
-Version: 4.1.3
-Release: 2%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
+Version: 4.1.4
+Release: 1%{?gh_date?%{gh_date}git%{gh_short}}%{?dist}
Summary: A validating SQL lexer and parser with a focus on MySQL dialect
Group: Development/Libraries
@@ -37,8 +37,8 @@ BuildRequires: php-composer(phpmyadmin/motranslator) < 4
BuildRequires: php-composer(phpmyadmin/motranslator) >= 3.0
BuildRequires: php-mbstring
# For tests, from composer.json "require-dev": {
-# "phpunit/php-code-coverage": "~2.0 || ~3.0",
-# "phpunit/phpunit": "~4.8 || ~5.1"
+# "phpunit/php-code-coverage": "*",
+# "phpunit/phpunit": "~4.8 || ~5.7"
BuildRequires: php-composer(phpunit/phpunit)
%endif
# For autoloader
@@ -168,6 +168,9 @@ exit $ret
%changelog
+* Fri May 5 2017 Remi Collet <remi@remirepo.net> - 4.1.4-1
+- Update to 4.1.4
+
* Sun Apr 30 2017 Remi Collet <remi@remirepo.net> - 4.1.3-2
- fix lang files installation from review #1415686