summaryrefslogtreecommitdiffstats
path: root/php-phpmyadmin-shapefile.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpmyadmin-shapefile.spec')
-rw-r--r--php-phpmyadmin-shapefile.spec31
1 files changed, 12 insertions, 19 deletions
diff --git a/php-phpmyadmin-shapefile.spec b/php-phpmyadmin-shapefile.spec
index 9de0a6a..3c1a103 100644
--- a/php-phpmyadmin-shapefile.spec
+++ b/php-phpmyadmin-shapefile.spec
@@ -7,9 +7,7 @@
# Please, preserve the changelog entries
#
-##TODO next version will have tests back
-
-%global gh_commit ee3413bda4cfc5683f088c2f232aab5b27339781
+%global gh_commit e23b767f2a81f61fee3fc09fc062879985f3e224
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpmyadmin
%global gh_project shapefile
@@ -18,7 +16,7 @@
%global ns_project ShapeFile
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.0
+Version: 2.1
Release: 1%{?dist}
Summary: ESRI ShapeFile library for PHP
@@ -31,7 +29,8 @@ BuildArch: noarch
%if %{with_tests}
BuildRequires: php(language) >= 5.4
# For tests, from composer.json "require-dev": {
-# "phpunit/phpunit": "~5.2 || ~4.8"
+# "phpunit/php-code-coverage": "*",
+# "phpunit/phpunit": "~4.8 || ~5.7"
BuildRequires: php-composer(phpunit/phpunit) >= 4.8
%endif
# For autoloader
@@ -97,21 +96,12 @@ cat << 'EOF' | tee vendor/autoload.php
require '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit --no-coverage || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit --no-coverage || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --no-coverage --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --no-coverage --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
@@ -128,6 +118,9 @@ exit $ret
%changelog
+* Mon May 15 2017 Remi Collet <remi@remirepo.net> - 2.1-1
+- Update to 2.1
+
* Mon Jan 23 2017 Remi Collet <remi@remirepo.net> - 2.0-1
- update to 3.0 with vendor namespace