summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--composer.json32
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-phpmyadmin-shapefile.spec132
4 files changed, 196 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..9a54f91
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,32 @@
+{
+ "name": "phpmyadmin/shapefile",
+ "description": "ESRI ShapeFile library for PHP",
+ "license": "GPL-2.0+",
+ "keywords": ["shapefile", "shp", "geo", "geospatial", "dbf", "ESRI", "shape"],
+ "homepage": "https://github.com/phpmyadmin/shapefile",
+ "authors": [
+ {
+ "name": "The phpMyAdmin Team",
+ "email": "developers@phpmyadmin.net",
+ "homepage": "https://www.phpmyadmin.net/team/"
+ }
+ ],
+ "support": {
+ "issues": "https://github.com/phpmyadmin/shapefile/issues",
+ "source": "https://github.com/phpmyadmin/shapefile"
+ },
+ "require": {
+ "php": ">=5.4.0"
+ },
+ "suggest": {
+ "ext-dbase": "For dbf files parsing"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "~5.2 || ~4.8"
+ },
+ "autoload": {
+ "psr-4": {
+ "ShapeFile\\": "src"
+ }
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..87d223d
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-phpmyadmin-shapefile.spec b/php-phpmyadmin-shapefile.spec
new file mode 100644
index 0000000..66b18d1
--- /dev/null
+++ b/php-phpmyadmin-shapefile.spec
@@ -0,0 +1,132 @@
+# remirepo/fedora spec file for php-phpmyadmin-shapefile
+#
+# Copyright (c) 2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+
+##TODO next version will have tests back
+
+%global gh_commit cb650f2900c69c1f864715c29f40ef912e112f7e
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner phpmyadmin
+%global gh_project shapefile
+%global with_tests 0%{!?_without_tests:1}
+%global psr0 ShapeFile
+
+Name: php-%{gh_owner}-%{gh_project}
+Version: 1.2
+Release: 1%{?dist}
+Summary: ESRI ShapeFile library for PHP
+
+Group: Development/Libraries
+License: GPLv2+
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
+
+BuildArch: noarch
+%if %{with_tests}
+BuildRequires: php(language) >= 5.4
+# For tests, from composer.json "require-dev": {
+# "phpunit/phpunit": "~5.2 || ~4.8"
+BuildRequires: php-composer(phpunit/phpunit) >= 4.8
+%endif
+# For autoloader
+BuildRequires: php-composer(fedora/autoloader)
+
+# From composer.json, "require": {
+# "php": ">=5.4.0"
+Requires: php(language) >= 5.4
+# From phpcompatinfo report for 1.2
+# nothing
+# From composer.json, "suggest": {
+# "ext-dbase": "For dbf files parsing"
+%if 0%{?fedora} >= 21
+Suggests: php-dbase
+%endif
+# For generated autoloader
+Requires: php-composer(fedora/autoloader)
+
+# Composer
+Provides: php-composer(%{gh_owner}/%{gh_project}) = %{version}
+
+
+%description
+Currently the 2D and 3D variants except MultiPatch of the ShapeFile format
+as defined in [1].
+
+The library currently supports reading and editing of ShapeFiles and the
+Associated information (DBF file). There are a lot of things that can be
+improved in the code, if you are interested in developing, helping with the
+documentation, making translations or offering new ideas please contact us.
+
+[1] https://www.esri.com/library/whitepapers/pdfs/shapefile.pdf
+
+Autoloader: %{_datadir}/php/%{psr0}/autoload.php
+
+
+%prep
+%setup -q -n %{gh_project}-%{gh_commit}
+
+
+%build
+: Create autoloader
+cat <<'AUTOLOAD' | tee src/autoload.php
+<?php
+/* Autoloader for %{name} and its dependencies */
+require_once '%{_datadir}/php/Fedora/Autoloader/autoload.php';
+
+\Fedora\Autoloader\Autoload::addPsr4('%{psr0}\\', __DIR__);
+AUTOLOAD
+
+
+%install
+: Library
+mkdir -p %{buildroot}%{_datadir}/php
+cp -pr src %{buildroot}%{_datadir}/php/%{psr0}
+
+
+%check
+%if %{with_tests}
+mkdir vendor
+cat << 'EOF' | tee vendor/autoload.php
+<?php
+require '%{buildroot}%{_datadir}/php/%{psr0}/autoload.php';
+EOF
+
+# remirepo:11
+run=0
+ret=0
+if which php56; then
+ php56 %{_bindir}/phpunit --no-coverage || ret=1
+ run=1
+fi
+if which php71; then
+ php71 %{_bindir}/phpunit --no-coverage || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
+%{_bindir}/phpunit --no-coverage --verbose
+# remirepo:2
+fi
+exit $ret
+%else
+: Test suite disabled
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc composer.json
+%doc *.md
+%{_datadir}/php/%{psr0}
+
+
+%changelog
+* Sat Jan 21 2017 Remi Collet <remi@remirepo.net> - 1.2-1
+- initial package
+