summaryrefslogtreecommitdiffstats
path: root/php-phpmailer6.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-11-26 08:50:40 +0100
committerRemi Collet <remi@remirepo.net>2020-11-26 08:50:40 +0100
commitbdedaae6775ef4fa3da0d08505d22a16c499e911 (patch)
tree4fbd69753ab6afba01de2972eb99b0c180ca6236 /php-phpmailer6.spec
parent48fe40c50cdca749b9ff5f7fa30090bf6c94f56b (diff)
update to 6.2.0
add build dependency on yoast/phpunit-polyfills switch to phpunit7
Diffstat (limited to 'php-phpmailer6.spec')
-rw-r--r--php-phpmailer6.spec31
1 files changed, 21 insertions, 10 deletions
diff --git a/php-phpmailer6.spec b/php-phpmailer6.spec
index c68696f..832fa0b 100644
--- a/php-phpmailer6.spec
+++ b/php-phpmailer6.spec
@@ -7,7 +7,7 @@
# Please preserve changelog entries
#
# Github
-%global gh_commit 917ab212fa00dc6eacbb26e8bc387ebe40993bc1
+%global gh_commit e38888a75c070304ca5514197d4847a59a5c853f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner PHPMailer
%global gh_project PHPMailer
@@ -23,7 +23,7 @@
%global php_home %{_datadir}/php
Name: php-%{pk_project}%{major}
-Version: 6.1.8
+Version: 6.2.0
Release: 1%{?dist}
Summary: Full-featured email creation and transfer class for PHP
@@ -52,10 +52,15 @@ BuildRequires: php-openssl
BuildRequires: php-pcre
BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require-dev": {
-# "friendsofphp/php-cs-fixer": "^2.2",
-# "phpunit/phpunit": "^4.8 || ^5.7",
+# "dealerdirect/phpcodesniffer-composer-installer": "^0.7.0",
# "doctrine/annotations": "^1.2",
-BuildRequires: php-phpunit-PHPUnit >= 4.8
+# "phpcompatibility/php-compatibility": "^9.3.5",
+# "roave/security-advisories": "dev-latest",
+# "squizlabs/php_codesniffer": "^3.5.6",
+# "yoast/phpunit-polyfills": "^0.2.0"
+%global phpunit %{_bindir}/phpunit7
+BuildRequires: php-composer(yoast/phpunit-polyfills) >= 0.2.0
+BuildRequires: %{phpunit}
BuildRequires: %{_sbindir}/smtp-sink
%endif
@@ -77,11 +82,11 @@ Requires: php-mbstring
Requires: php-openssl
Requires: php-pcre
# From composer.json, "suggest": {
-# "psr/log": "For optional PSR-3 debug logging",
-# "league/oauth2-google": "Needed for Google XOAUTH2 authentication",
+# "ext-mbstring": "Needed to send email in multibyte encoding charset",
# "hayageek/oauth2-yahoo": "Needed for Yahoo XOAUTH2 authentication",
+# "league/oauth2-google": "Needed for Google XOAUTH2 authentication",
+# "psr/log": "For optional PSR-3 debug logging",
# "stevenmaguire/oauth2-microsoft": "Needed for Microsoft XOAUTH2 authentication",
-# "ext-mbstring": "Needed to send email in multibyte encoding charset",
# "symfony/polyfill-mbstring": "To support UTF-8 if the Mbstring PHP extension is not enabled (^1.2)"
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Suggests: php-composer(psr/log)
@@ -152,6 +157,7 @@ mkdir vendor
cat << 'EOF' | tee -a vendor/autoload.php
<?php
require_once '%{buildroot}/%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php';
+require_once '%{php_home}/Yoast/PHPUnitPolyfills/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('PHPMailer\\Test\\', dirname(__DIR__) . '/test');
EOF
@@ -171,10 +177,10 @@ popd
: Run upstream test suite
ret=0
-for cmd in php php71 php72 php73 php74 php80; do
+for cmd in php php72 php73 php74 php80; do
if which $cmd; then
$cmd -d "sendmail_path=$PWD/test/fakesendmail.sh -t -i " \
- %{_bindir}/phpunit --exclude slow,pop3,languages --verbose || ret=1
+ %{phpunit} --exclude slow,pop3,languages --verbose || ret=1
fi
done
@@ -197,6 +203,11 @@ exit $ret
%changelog
+* Thu Nov 26 2020 Remi Collet <remi@remirepo.net> - 6.2.0-1
+- update to 6.2.0
+- add build dependency on yoast/phpunit-polyfills
+- switch to phpunit7
+
* Sat Oct 10 2020 Remi Collet <remi@remirepo.net> - 6.1.8-1
- update to 6.1.8