summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-06-14 14:17:21 +0200
committerRemi Collet <remi@php.net>2022-06-14 14:17:21 +0200
commitba0618681fb688564b5ebec010b1c702a5505064 (patch)
treeb16f5617653e4d1a9652a5ac453ad1eb2db7a366
parentb9a7c31848e3ca9b7944826e4b224803640d565a (diff)
update to 6.6.2
-rw-r--r--composer.json6
-rw-r--r--php-phpmailer6.spec9
2 files changed, 9 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index b13732b..1db6f03 100644
--- a/composer.json
+++ b/composer.json
@@ -39,8 +39,8 @@
"require-dev": {
"dealerdirect/phpcodesniffer-composer-installer": "^0.7.0",
"doctrine/annotations": "^1.2",
- "php-parallel-lint/php-console-highlighter": "^0.5.0",
- "php-parallel-lint/php-parallel-lint": "^1.3.1",
+ "php-parallel-lint/php-console-highlighter": "^1.0.0",
+ "php-parallel-lint/php-parallel-lint": "^1.3.2",
"phpcompatibility/php-compatibility": "^9.3.5",
"roave/security-advisories": "dev-latest",
"squizlabs/php_codesniffer": "^3.6.2",
@@ -70,7 +70,7 @@
"test": "./vendor/bin/phpunit --no-coverage",
"coverage": "./vendor/bin/phpunit",
"lint": [
- "@php ./vendor/php-parallel-lint/php-parallel-lint/parallel-lint . -e php,phps --exclude vendor --exclude .git --exclude build"
+ "@php ./vendor/php-parallel-lint/php-parallel-lint/parallel-lint . --show-deprecated -e php,phps --exclude vendor --exclude .git --exclude build"
]
}
}
diff --git a/php-phpmailer6.spec b/php-phpmailer6.spec
index 99779ab..a323067 100644
--- a/php-phpmailer6.spec
+++ b/php-phpmailer6.spec
@@ -7,7 +7,7 @@
# Please preserve changelog entries
#
# Github
-%global gh_commit e43bac82edc26ca04b36143a48bde1c051cfd5b1
+%global gh_commit b52ed06864fdda81b82ec8bf564cf15d45ed4f95
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner PHPMailer
%global gh_project PHPMailer
@@ -23,7 +23,7 @@
%global php_home %{_datadir}/php
Name: php-%{pk_project}%{major}
-Version: 6.6.0
+Version: 6.6.2
Release: 1%{?dist}
Summary: Full-featured email creation and transfer class for PHP
@@ -183,7 +183,7 @@ popd
: Run upstream test suite
ret=0
-for cmd in php php74 php80 php81; do
+for cmd in php php74 php80 php81 php82; do
if which $cmd; then
$cmd -d "sendmail_path=$PWD/test/fakesendmail.sh -t -i " \
%{phpunit} --exclude slow,pop3,languages --verbose || ret=1
@@ -209,6 +209,9 @@ exit $ret
%changelog
+* Tue Jun 14 2022 Remi Collet <remi@remirepo.net> - 6.6.2-1
+- update to 6.6.2
+
* Mon Feb 28 2022 Remi Collet <remi@remirepo.net> - 6.6.0-1
- update to 6.6.0