summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-01 12:50:54 +0200
committerRemi Collet <remi@remirepo.net>2021-09-01 12:50:54 +0200
commitb56a13f814000bb563a7c96fc679cf95097d9e3b (patch)
tree54476c9701a58a9cc8705ff949eab72ba9c7ab05
parent1c07c09dcde66ac6383fb5a366ac220658d512aa (diff)
update to 6.5.1
-rw-r--r--composer.json12
-rw-r--r--php-phpmailer6-layout.patch11
-rw-r--r--php-phpmailer6.spec17
3 files changed, 25 insertions, 15 deletions
diff --git a/composer.json b/composer.json
index 58393b2..28557f5 100644
--- a/composer.json
+++ b/composer.json
@@ -34,10 +34,12 @@
"require-dev": {
"dealerdirect/phpcodesniffer-composer-installer": "^0.7.0",
"doctrine/annotations": "^1.2",
+ "php-parallel-lint/php-console-highlighter": "^0.5.0",
+ "php-parallel-lint/php-parallel-lint": "^1.3",
"phpcompatibility/php-compatibility": "^9.3.5",
"roave/security-advisories": "dev-latest",
- "squizlabs/php_codesniffer": "^3.5.6",
- "yoast/phpunit-polyfills": "^0.2.0"
+ "squizlabs/php_codesniffer": "^3.6.0",
+ "yoast/phpunit-polyfills": "^1.0.0"
},
"suggest": {
"ext-mbstring": "Needed to send email in multibyte encoding charset or decode encoded addresses",
@@ -60,6 +62,10 @@
"license": "LGPL-2.1-only",
"scripts": {
"check": "./vendor/bin/phpcs",
- "test": "./vendor/bin/phpunit"
+ "test": "./vendor/bin/phpunit --no-coverage",
+ "coverage": "./vendor/bin/phpunit",
+ "lint": [
+ "@php ./vendor/php-parallel-lint/php-parallel-lint/parallel-lint . -e php,phps --exclude vendor --exclude .git --exclude build"
+ ]
}
}
diff --git a/php-phpmailer6-layout.patch b/php-phpmailer6-layout.patch
index 8f254ec..b23da87 100644
--- a/php-phpmailer6-layout.patch
+++ b/php-phpmailer6-layout.patch
@@ -1,12 +1,11 @@
diff -up ./src/PHPMailer.php.rpm ./src/PHPMailer.php
---- ./src/PHPMailer.php.rpm 2021-02-24 09:34:44.854775099 +0100
-+++ ./src/PHPMailer.php 2021-02-24 09:35:04.783696615 +0100
-@@ -2215,7 +2215,7 @@ class PHPMailer
- ];
+--- ./src/PHPMailer.php.rpm 2021-09-01 12:46:30.267656729 +0200
++++ ./src/PHPMailer.php 2021-09-01 12:47:43.003485872 +0200
+@@ -2253,6 +2253,7 @@ class PHPMailer
if (empty($lang_path)) {
//Calculate an absolute path so it can work if CWD is not here
-- $lang_path = dirname(__DIR__) . DIRECTORY_SEPARATOR . 'language' . DIRECTORY_SEPARATOR;
+ $lang_path = dirname(__DIR__) . DIRECTORY_SEPARATOR . 'language' . DIRECTORY_SEPARATOR;
+ $lang_path = __DIR__ . DIRECTORY_SEPARATOR . 'language' . DIRECTORY_SEPARATOR;
}
+
//Validate $langcode
- if (!preg_match('/^[a-z]{2}(?:_[a-zA-Z]{2})?$/', $langcode)) {
diff --git a/php-phpmailer6.spec b/php-phpmailer6.spec
index c449a4a..2b68544 100644
--- a/php-phpmailer6.spec
+++ b/php-phpmailer6.spec
@@ -7,7 +7,7 @@
# Please preserve changelog entries
#
# Github
-%global gh_commit a5b5c43e50b7fba655f793ad27303cd74c57363c
+%global gh_commit dd803df5ad7492e1b40637f7ebd258fee5ca7355
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner PHPMailer
%global gh_project PHPMailer
@@ -23,7 +23,7 @@
%global php_home %{_datadir}/php
Name: php-%{pk_project}%{major}
-Version: 6.5.0
+Version: 6.5.1
Release: 1%{?dist}
Summary: Full-featured email creation and transfer class for PHP
@@ -53,12 +53,14 @@ BuildRequires: php-fedora-autoloader-devel
# From composer.json, "require-dev": {
# "dealerdirect/phpcodesniffer-composer-installer": "^0.7.0",
# "doctrine/annotations": "^1.2",
+# "php-parallel-lint/php-console-highlighter": "^0.5.0",
+# "php-parallel-lint/php-parallel-lint": "^1.3",
# "phpcompatibility/php-compatibility": "^9.3.5",
# "roave/security-advisories": "dev-latest",
-# "squizlabs/php_codesniffer": "^3.5.6",
-# "yoast/phpunit-polyfills": "^0.2.0"
+# "squizlabs/php_codesniffer": "^3.6.0",
+# "yoast/phpunit-polyfills": "^1.0.0"
%global phpunit %{_bindir}/phpunit7
-BuildRequires: php-composer(yoast/phpunit-polyfills) >= 0.2.0
+BuildRequires: php-composer(yoast/phpunit-polyfills) >= 1.0.0
BuildRequires: %{phpunit}
BuildRequires: %{_sbindir}/smtp-sink
%endif
@@ -181,7 +183,7 @@ popd
: Run upstream test suite
ret=0
-for cmd in php php72 php73 php74 php80; do
+for cmd in php php73 php74 php80; do
if which $cmd; then
$cmd -d "sendmail_path=$PWD/test/fakesendmail.sh -t -i " \
%{phpunit} --exclude slow,pop3,languages --verbose || ret=1
@@ -207,6 +209,9 @@ exit $ret
%changelog
+* Wed Sep 1 2021 Remi Collet <remi@remirepo.net> - 6.5.1-1
+- update to 6.5.1
+
* Thu Jun 17 2021 Remi Collet <remi@remirepo.net> - 6.5.0-1
- update to 6.5.0