summaryrefslogtreecommitdiffstats
path: root/php-phpdocumentor-type-resolver1.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpdocumentor-type-resolver1.spec')
-rw-r--r--php-phpdocumentor-type-resolver1.spec25
1 files changed, 18 insertions, 7 deletions
diff --git a/php-phpdocumentor-type-resolver1.spec b/php-phpdocumentor-type-resolver1.spec
index 6dd7b2e..8007d68 100644
--- a/php-phpdocumentor-type-resolver1.spec
+++ b/php-phpdocumentor-type-resolver1.spec
@@ -10,8 +10,8 @@
%global github_owner phpDocumentor
%global github_name TypeResolver
-%global github_version 1.3.0
-%global github_commit e878a14a65245fbe78f8080eba03b47c3b705651
+%global github_version 1.4.0
+%global github_commit 6a467b8989322d92aa1c8bf2bebcc6e5c2ba55c0
%global composer_vendor phpdocumentor
%global composer_project type-resolver
@@ -50,7 +50,15 @@ BuildArch: noarch
%if %{with tests}
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
+# remirepo:1
+%if 0%{?fedora} >= 31 || 0%{?rhel} >= 9
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9
+# remirepo:4
+%else
+%global phpunit %{_bindir}/phpunit8
BuildRequires: phpunit8
+%endif
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(phpdocumentor/reflection-common) >= %{reflection_common_min_ver} with php-composer(phpdocumentor/reflection-common) < %{reflection_common_max_ver})
@@ -141,11 +149,11 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-for cmdarg in php php72 php73 php74 php80; do
+for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
$1 -d auto_prepend_file=$PWD/bootstrap.php \
- ${2:-%{_bindir}/phpunit8} --verbose --bootstrap bootstrap.php \
+ ${2:-%{_bindir}/phpunit9} --verbose --no-coverage --bootstrap bootstrap.php \
|| RETURN_CODE=1
fi
done
@@ -164,12 +172,15 @@ exit $RETURN_CODE
%doc examples
%{phpdir}/phpDocumentor/Reflection%{ns_major}/autoload-type-resolver.php
%{phpdir}/phpDocumentor/Reflection%{ns_major}/FqsenResolver.php
-%{phpdir}/phpDocumentor/Reflection%{ns_major}/Type.php
-%{phpdir}/phpDocumentor/Reflection%{ns_major}/TypeResolver.php
-%{phpdir}/phpDocumentor/Reflection%{ns_major}/Types
+%{phpdir}/phpDocumentor/Reflection%{ns_major}/Type*
+%{phpdir}/phpDocumentor/Reflection%{ns_major}/PseudoType*
%changelog
+* Fri Sep 18 2020 Remi Collet <remi@remirepo.net> - 1.4.0-1
+- update to 1.4.0
+- switch to phpunit9
+
* Mon Jun 29 2020 Remi Collet <remi@remirepo.net> - 1.3.0-1
- update to 1.3.0