summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--composer.json27
-rwxr-xr-xmakesrc.sh71
-rw-r--r--php-phpdocumentor-type-resolver1.spec191
5 files changed, 300 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..82ead15
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,27 @@
+{
+ "name": "phpdocumentor/type-resolver",
+ "type": "library",
+ "license": "MIT",
+ "authors": [
+ {"name": "Mike van Riel", "email": "me@mikevanriel.com"}
+ ],
+ "require": {
+ "php": "^5.5 || ^7.0",
+ "phpdocumentor/reflection-common": "^1.0"
+ },
+ "autoload": {
+ "psr-4": {"phpDocumentor\\Reflection\\": ["src/"]}
+ },
+ "autoload-dev": {
+ "psr-4": {"phpDocumentor\\Reflection\\": ["tests/unit"]}
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^5.2||^4.8.24",
+ "mockery/mockery": "^0.9.4"
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "1.0.x-dev"
+ }
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..4ad1051
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,71 @@
+#/bin/sh
+
+GIT=`which git`
+RPM=`which rpm`
+
+if [ -z "$GIT" ]
+then
+ echo "ERROR: 'git' command not found" 1>&2
+ exit 1
+elif [ -z "$RPM" ]
+then
+ echo "ERROR: 'rpm' command not found" 1>&2
+ exit 1
+fi
+
+function print {
+ echo -e "\e[0;33m>>>>> ${1}\e[0m"
+}
+
+if [ -x "$1" ]
+then
+ SPEC=$1
+else
+ SPEC=`ls *.spec | head -1`
+fi
+
+NAME=`echo $SPEC | sed 's#\.spec##'`
+VERSION=`egrep '%global\s*github_version' $SPEC | awk '{print $3}'`
+
+print "SPEC = $SPEC"
+print "NAME = $NAME"
+
+GIT_OWNER=`egrep '%global\s*github_owner' $SPEC | awk '{print $3}'`
+GIT_NAME=`egrep '%global\s*github_name' $SPEC | awk '{print $3}'`
+GIT_COMMIT=`egrep '%global\s*github_commit' $SPEC | awk '{print $3}'`
+GIT_REPO=https://github.com/${GIT_OWNER}/${GIT_NAME}
+GIT_DIR=`echo $GIT_REPO | sed 's#.*/##'`
+
+print "GIT_OWNER = $GIT_OWNER"
+print "GIT_NAME = $GIT_NAME"
+print "GIT_COMMIT = $GIT_COMMIT"
+print "GIT_REPO = $GIT_REPO"
+print "GIT_DIR = $GIT_DIR"
+
+TEMP_DIR=$(mktemp --dir)
+TAR_FILE=$PWD/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+CMP_FILE=$PWD/composer.json
+
+pushd $TEMP_DIR
+ print "Cloning git repo..."
+ $GIT clone $GIT_REPO
+
+ pushd $GIT_DIR
+ print "Checking out commit..."
+ $GIT checkout $GIT_COMMIT
+ cp composer.json $CMP_FILE
+ popd
+
+ TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
+ print "TAR_DIR = $TAR_DIR"
+
+ mv $GIT_DIR $TAR_DIR
+
+ print "TAR_FILE = $TAR_FILE"
+
+ [ -e $TAR_FILE ] && rm -f $TAR_FILE
+ tar --exclude-vcs -czf $TAR_FILE $TAR_DIR
+ chmod 0644 $TAR_FILE
+popd
+
+rm -rf $TEMP_DIR
diff --git a/php-phpdocumentor-type-resolver1.spec b/php-phpdocumentor-type-resolver1.spec
new file mode 100644
index 0000000..9f66a77
--- /dev/null
+++ b/php-phpdocumentor-type-resolver1.spec
@@ -0,0 +1,191 @@
+# remirepo spec file for php-phpdocumentor-type-resolver, from
+#
+# Fedora spec file for php-phpdocumentor-type-resolver
+#
+# Copyright (c) 2017 Shawn Iwinski <shawn@iwin.ski>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner phpDocumentor
+%global github_name TypeResolver
+%global github_version 0.4.0
+%global github_commit 9c977708995954784726e25d0cd1dddf4e65b0f7
+
+%global composer_vendor phpdocumentor
+%global composer_project type-resolver
+
+# "php": "^5.5 || ^7.0"
+%global php_min_ver 5.5
+# "mockery/mockery": "^0.9.4"
+%global mockery_min_ver 0.9.4
+%global mockery_max_ver 1.0
+# "phpdocumentor/reflection-common": "^1.0"
+%global reflection_common_min_ver 1.0
+%global reflection_common_max_ver 2.0
+
+# Build using "--without tests" to disable tests
+%global with_tests 0%{!?_without_tests:1}
+
+%{!?phpdir: %global phpdir %{_datadir}/php}
+
+Name: php-%{composer_vendor}-%{composer_project}
+Version: %{github_version}
+Release: 5%{?github_release}%{?dist}
+Summary: A PSR-5 based resolver of Class names, Types and Structural Element Names
+
+Group: Development/Libraries
+License: MIT
+URL: https://github.com/%{github_owner}/%{github_name}
+
+# GitHub export does not include tests.
+# Run php-phpdocumentor-type-resolver-get-source.sh to create full source.
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+## composer.json
+BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-composer(phpunit/phpunit)
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: (php-composer(phpdocumentor/reflection-common) >= %{reflection_common_min_ver} with php-composer(phpdocumentor/reflection-common) < %{reflection_common_max_ver})
+BuildRequires: (php-composer(mockery/mockery) >= %{mockery_min_ver} with php-composer(mockery/mockery) < %{mockery_max_ver})
+# remirepo:6
+%else
+BuildRequires: php-composer(phpdocumentor/reflection-common) < %{reflection_common_max_ver}
+BuildRequires: php-composer(phpdocumentor/reflection-common) >= %{reflection_common_min_ver}
+BuildRequires: php-composer(mockery/mockery) < %{mockery_max_ver}
+BuildRequires: php-composer(mockery/mockery) >= %{mockery_min_ver}
+%endif
+## phpcompatinfo (computed from version 0.4.0)
+BuildRequires: php-reflection
+BuildRequires: php-spl
+BuildRequires: php-tokenizer
+## Autoloader
+BuildRequires: php-fedora-autoloader-devel
+%endif
+
+# composer.json
+Requires: php(language) >= %{php_min_ver}
+# remirepo:1
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+Requires: (php-composer(phpdocumentor/reflection-common) >= %{reflection_common_min_ver} with php-composer(phpdocumentor/reflection-common) < %{reflection_common_max_ver})
+# remirepo:4
+%else
+Requires: php-composer(phpdocumentor/reflection-common) >= %{reflection_common_min_ver}
+Requires: php-composer(phpdocumentor/reflection-common) < %{reflection_common_max_ver}
+%endif
+# phpcompatinfo (computed from version 0.4.0)
+Requires: php-spl
+Requires: php-tokenizer
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
+%description
+The specification on types in DocBlocks (PSR-5) describes various keywords
+and special constructs but also how to statically resolve the partial name
+of a Class into a Fully Qualified Class Name (FQCN).
+
+PSR-5 also introduces an additional way to describe deeper elements than
+Classes, Interfaces and Traits called the Fully Qualified Structural Element
+Name (FQSEN). Using this it is possible to refer to methods, properties and
+class constants but also functions and global constants.
+
+This package provides two Resolvers that are capable of:
+1. Returning a series of Value Object for given expression while resolving any
+ partial class names, and
+2. Returning an FQSEN object after resolving any partial Structural Element
+ Names into Fully Qualified Structural Element names.
+
+Autoloader: %{phpdir}/phpDocumentor/Reflection/autoload-type-resolver.php
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+: Update examples autoload require
+sed "s#.*require.*vendor.*/autoload.php.*#require_once '%{phpdir}/phpDocumentor/Reflection/autoload-type-resolver.php';#" \
+ -i examples/*
+
+
+%build
+: Create autoloader
+%{_bindir}/phpab --template fedora --output src/autoload-type-resolver.php src
+cat <<'AUTOLOAD' | tee -a src/autoload-type-resolver.php
+
+\Fedora\Autoloader\Dependencies::required([
+ '%{phpdir}/phpDocumentor/Reflection/autoload-common.php',
+]);
+AUTOLOAD
+
+
+%install
+mkdir -p %{buildroot}%{phpdir}/phpDocumentor/Reflection
+cp -rp src/* %{buildroot}%{phpdir}/phpDocumentor/Reflection/
+
+
+%check
+%if %{with_tests}
+: Create tests bootstrap
+cat <<'BOOTSTRAP' | tee bootstrap.php
+<?php
+require '%{buildroot}%{phpdir}/phpDocumentor/Reflection/autoload-type-resolver.php';
+
+\Fedora\Autoloader\Autoload::addPsr4('phpDocumentor\\Reflection\\', __DIR__.'/tests/unit');
+
+\Fedora\Autoloader\Dependencies::required([
+ '%{phpdir}/Mockery/autoload.php',
+]);
+BOOTSTRAP
+
+: Adjust listener path
+sed 's#vendor/mockery/mockery/library#%{phpdir}#' phpunit.xml.dist > phpunit.xml
+
+: Upstream tests
+RETURN_CODE=0
+PHPUNIT=$(which phpunit)
+for PHP_EXEC in php php56 php70 php71 php72 php73; do
+ if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
+ $PHP_EXEC -d auto_prepend_file=$PWD/bootstrap.php \
+ $PHPUNIT --verbose --bootstrap bootstrap.php \
+ || RETURN_CODE=1
+ fi
+done
+exit $RETURN_CODE
+%else
+: Tests skipped
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%doc examples
+%{phpdir}/phpDocumentor/Reflection/autoload-type-resolver.php
+%{phpdir}/phpDocumentor/Reflection/FqsenResolver.php
+%{phpdir}/phpDocumentor/Reflection/Type.php
+%{phpdir}/phpDocumentor/Reflection/TypeResolver.php
+%{phpdir}/phpDocumentor/Reflection/Types
+
+
+%changelog
+* Fri Dec 7 2018 Remi Collet <remi@remirepo.net> - 0.4.0-5
+- use range dependencies
+
+* Mon Jul 17 2017 Shawn Iwinski <shawn@iwin.ski> - 0.4.0-1
+- Update to 0.4.0 (RHBZ #1460503)
+- Add "get source" script because upstream attributes removed tests from snapshot
+
+* Sat Mar 11 2017 Shawn Iwinski <shawn@iwin.ski> - 0.2.1-1
+- Initial package