summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-14 15:11:05 +0200
committerRemi Collet <remi@php.net>2022-10-14 15:11:05 +0200
commitcd8f14aa3718f2c1e5a93b00def1e54220aa5b0d (patch)
treec6ec31f5f3a93e0cbe23a5ca8227901d7a202bc7
parented2c969241457040547938eb4070684781dca66c (diff)
update to 1.6.2
raise dependency on PHP 7.4
-rw-r--r--composer.json17
-rw-r--r--php-phpdocumentor-type-resolver1.spec16
2 files changed, 25 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 4dbf623..a7ae10f 100644
--- a/composer.json
+++ b/composer.json
@@ -10,12 +10,17 @@
}
],
"require": {
- "php": "^7.2 || ^8.0",
+ "php": "^7.4 || ^8.0",
"phpdocumentor/reflection-common": "^2.0"
},
"require-dev": {
"ext-tokenizer": "*",
- "psalm/phar": "^4.8"
+ "phpunit/phpunit": "^9.5",
+ "phpstan/phpstan": "^1.8",
+ "phpstan/phpstan-phpunit": "^1.1",
+ "phpstan/extension-installer": "^1.1",
+ "vimeo/psalm": "^4.25",
+ "rector/rector": "^0.13.9"
},
"autoload": {
"psr-4": {
@@ -31,5 +36,13 @@
"branch-alias": {
"dev-1.x": "1.x-dev"
}
+ },
+ "config": {
+ "platform": {
+ "php": "7.4.0"
+ },
+ "allow-plugins": {
+ "phpstan/extension-installer": true
+ }
}
}
diff --git a/php-phpdocumentor-type-resolver1.spec b/php-phpdocumentor-type-resolver1.spec
index 58e1069..43cf185 100644
--- a/php-phpdocumentor-type-resolver1.spec
+++ b/php-phpdocumentor-type-resolver1.spec
@@ -10,8 +10,8 @@
%global github_owner phpDocumentor
%global github_name TypeResolver
-%global github_version 1.6.1
-%global github_commit 77a32518733312af16a44300404e945338981de3
+%global github_version 1.6.2
+%global github_commit 48f445a408c131e38cab1c235aa6d2bb7a0bb20d
%global composer_vendor phpdocumentor
%global composer_project type-resolver
@@ -20,8 +20,8 @@
# Install in reflection-common tree
%global ns_major 2
-# "php": "^7.2 || ^8.0"
-%global php_min_ver 7.2
+# "php": "^7.4 || ^8.0"
+%global php_min_ver 7.4
# "phpdocumentor/reflection-common": "^2.0"
%global reflection_common_min_ver 2.0
%global reflection_common_max_ver 3
@@ -51,7 +51,7 @@ BuildArch: noarch
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit9
+BuildRequires: phpunit9 >= 9.5
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(phpdocumentor/reflection-common) >= %{reflection_common_min_ver} with php-composer(phpdocumentor/reflection-common) < %{reflection_common_max_ver})
@@ -142,7 +142,7 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 -d auto_prepend_file=$PWD/bootstrap.php \
@@ -171,6 +171,10 @@ exit $RETURN_CODE
%changelog
+* Fri Oct 14 2022 Remi Collet <remi@remirepo.net> - 1.6.2-1
+- update to 1.6.2
+- raise dependency on PHP 7.4
+
* Wed Mar 30 2022 Remi Collet <remi@remirepo.net> - 1.6.1-1
- update to 1.6.1