summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-04-24 15:41:18 +0200
committerRemi Collet <remi@remirepo.net>2017-04-24 15:41:18 +0200
commit5ecfb0f3624e9fcd16ca70d4e133123040b3a6ec (patch)
tree259b87ca265b64fe2692a932bd2da2a6ec890213
parenta44fb5f13911f7a4f2141127cecdc1307b55aed2 (diff)
sync with Fedora
-rw-r--r--.gitignore7
-rw-r--r--php-phpdocumentor-reflection.spec27
2 files changed, 24 insertions, 10 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-phpdocumentor-reflection.spec b/php-phpdocumentor-reflection.spec
index 2b37e1a..ea4027c 100644
--- a/php-phpdocumentor-reflection.spec
+++ b/php-phpdocumentor-reflection.spec
@@ -1,6 +1,7 @@
# spec file for php-phpdocumentor-reflection
#
-# Copyright (c) 2016-2017 Remi Collet
+# Copyright (c) 2016 Remi Collet
+# 2017 Remi Collet, Shawn Iwinski
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -16,7 +17,7 @@
Name: php-phpdocumentor-reflection
Version: 1.0.7
-Release: 1%{?dist}
+Release: 3%{?dist}
Summary: Reflection library to do Static Analysis for PHP Projects
Group: Development/Libraries
@@ -37,23 +38,26 @@ Provides: bundled(nikic/php-parser) = %{php_parser_version}
# Temporary, missing in old versions
Source2: https://raw.githubusercontent.com/phpDocumentor/Reflection/develop/LICENSE
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-theseer-autoload
# For tests
%if %{with_tests}
BuildRequires: php(language) >= 5.3.3
BuildRequires: php-composer(psr/log) >= 1.0
+BuildRequires: php-composer(psr/log) < 2
%if ! %{with_php_parser}
BuildRequires: php-composer(nikic/php-parser) >= 0.9.4
+BuildRequires: php-composer(nikic/php-parser) < 0.10
%endif
BuildRequires: php-composer(phpdocumentor/reflection-docblock) >= 2.0
+BuildRequires: php-composer(phpdocumentor/reflection-docblock) < 3
# From composer.json, "require-dev": {
# "behat/behat": "~2.4",
# "phpunit/phpunit": "~4.0",
# "mockery/mockery": "~0.8"
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
BuildRequires: php-composer(mockery/mockery) >= 0.8
+BuildRequires: php-composer(mockery/mockery) < 1
%endif
# From composer.json, require
@@ -130,7 +134,11 @@ cp %{SOURCE2} LICENSE
cat << 'EOF' | tee -a src/phpDocumentor/Reflection/autoload.php
// Dependencies
require_once '%{_datadir}/php/Psr/Log/autoload.php';
-require_once '%{_datadir}/php/phpDocumentor/Reflection/DocBlock/autoload.php';
+if (file_exists('%{_datadir}/php/phpDocumentor/Reflection/DocBlock2/autoload.php')) {
+ require_once '%{_datadir}/php/phpDocumentor/Reflection/DocBlock2/autoload.php';
+} else {
+ require_once '%{_datadir}/php/phpDocumentor/Reflection/DocBlock/autoload.php';
+}
%if ! %{with_php_parser}
require_once '%{_datadir}/php/PhpParser/autoload.php';
%endif
@@ -138,7 +146,6 @@ EOF
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{_datadir}/php
cp -pr src/* %{buildroot}%{_datadir}/php
@@ -168,12 +175,7 @@ fi
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE*
%doc *.md
@@ -182,6 +184,11 @@ rm -rf %{buildroot}
%changelog
+* Thu Apr 13 2017 Shawn Iwinski <shawn@iwin.ski> - 1.0.7-3
+- Add max versions to BuildRequires
+- Prepare for php-phpdocumentor-reflection-docblock =>
+ php-phpdocumentor-reflection-docblock2 dependency rename
+
* Thu Apr 14 2016 Remi Collet <remi@fedoraproject.org> - 1.0.7-1
- initial package, version 1.0.7
- bundle nikic/php-parser 0.9.4