summaryrefslogtreecommitdiffstats
path: root/php-phpdocumentor-reflection-docblock5.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-12 12:11:38 +0100
committerRemi Collet <remi@remirepo.net>2020-02-12 12:11:38 +0100
commit711ea5f9df368c3625933f65ab92a9671bbcd1e6 (patch)
treeb494987b8af3af0ef26e7430d7fee97f974f1bfe /php-phpdocumentor-reflection-docblock5.spec
parent285a92b9c11c3e2a01d09c87e67223b9dcc126f5 (diff)
update to 5.0.0
rename to php-phpdocumentor-reflection-docblock5 move to /usr/share/php/phpDocumentor/Reflection/DocBlock5 raise dependency on PHP 7.2 raise dependency on type-resolver 1 raise dependency on reflection-common 2 switch to phpunit8
Diffstat (limited to 'php-phpdocumentor-reflection-docblock5.spec')
-rw-r--r--php-phpdocumentor-reflection-docblock5.spec85
1 files changed, 43 insertions, 42 deletions
diff --git a/php-phpdocumentor-reflection-docblock5.spec b/php-phpdocumentor-reflection-docblock5.spec
index da2728d..a300f7f 100644
--- a/php-phpdocumentor-reflection-docblock5.spec
+++ b/php-phpdocumentor-reflection-docblock5.spec
@@ -1,4 +1,4 @@
-# Fedora/remirepo spec file for php-phpdocumentor-reflection-docblock4
+# Fedora/remirepo spec file for php-phpdocumentor-reflection-docblock5
#
# Copyright (c) 2017-2020 Remi Collet, Shawn Iwinski
# 2014-2015 Remi Collet
@@ -8,15 +8,15 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit da3fd972d6bafd628114f7e7e036f45944b62e9c
+%global gh_commit a48807183a4b819072f26e347bbd0b5199a9d15f
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpDocumentor
%global gh_project ReflectionDocBlock
-%global major 4
+%global major 5
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-phpdocumentor-reflection-docblock%{major}
-Version: 4.3.4
+Version: 5.0.0
Release: 1%{?dist}
Summary: DocBlock parser
@@ -25,29 +25,28 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
# GitHub export does not include tests.
# Run php-phpdocumentor-reflection-docblock-get-source.sh to create full source.
-Source0: %{name}-%{version}-%{gh_commit}.tar.gz
-Source1: %{name}-get-source.sh
+Source0: %{name}-%{version}-%{gh_short}.tar.gz
+Source1: makesrc.sh
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
-BuildRequires: php(language) >= 7.0
+BuildRequires: php(language) >= 7.2
+BuildRequires: php-filter
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(phpdocumentor/reflection-common) >= 1.0.0 with php-composer(phpdocumentor/reflection-common) < 3)
-BuildRequires: (php-composer(phpdocumentor/type-resolver) >= 0.4.0 with php-composer(phpdocumentor/type-resolver) < 0.5)
+BuildRequires: (php-composer(phpdocumentor/type-resolver) >= 1.0 with php-composer(phpdocumentor/type-resolver) < 2)
BuildRequires: (php-composer(webmozart/assert) >= 1.0 with php-composer(webmozart/assert) < 2)
+BuildRequires: (php-composer(phpdocumentor/reflection-common) >= 2.0 with php-composer(phpdocumentor/reflection-common) < 3)
# remirepo:5
%else
-BuildRequires: php-phpdocumentor-reflection-common >= 1.0.0
-BuildRequires: php-phpdocumentor-type-resolver >= 0.4.0
-BuildRequires: php-webmozart-assert >= 1.0
+BuildRequires: php-phpdocumentor-reflection-common2
+BuildRequires: php-phpdocumentor-type-resolver1
+BuildRequires: php-webmozart-assert
%endif
# From composer.json, require-dev
-# "mockery/mockery": "^1.0",
-# "phpdocumentor/type-resolver": "0.4.*",
-# "phpunit/phpunit": "^6.4",
-# "doctrine/instantiator": "^1.0.5"
+# "mockery/mockery": "^1",
+# "doctrine/instantiator": "^1"
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(mockery/mockery) >= 1.0 with php-composer(mockery/mockery) < 2)
@@ -55,34 +54,34 @@ BuildRequires: (php-composer(mockery/mockery) >= 1.0 with php-composer(mockery/m
%else
BuildRequires: php-mockery >= 1.0
%endif
-BuildRequires: phpunit6 >= 6.4
-# From phpcompatinfo report for 4.3.2
+BuildRequires: phpunit8
+# From phpcompatinfo report for 5.0.0
BuildRequires: php-reflection
-BuildRequires: php-filter
BuildRequires: php-pcre
BuildRequires: php-spl
%endif
# From composer.json, require
-# "php": ">=7.0"
-# "phpdocumentor/reflection-common": "^1.0.0 || ^2.0.0",
-# "phpdocumentor/type-resolver": "~0.4 || ^1.0.0",
-# "webmozart/assert": "^1.0"
-Requires: php(language) >= 7.0
+# "php": "^7.2",
+# "phpdocumentor/type-resolver": "^1.0",
+# "webmozart/assert": "^1",
+# "phpdocumentor/reflection-common": "^2.0",
+# "ext-filter": "^7.1"
+Requires: php(language) >= 7.2
+Requires: php-filter
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(phpdocumentor/reflection-common) >= 1.0.0 with php-composer(phpdocumentor/reflection-common) < 3)
-Requires: (php-composer(phpdocumentor/type-resolver) >= 0.4.0 with php-composer(phpdocumentor/type-resolver) < 2)
+Requires: (php-composer(phpdocumentor/type-resolver) >= 1.0 with php-composer(phpdocumentor/type-resolver) < 2)
Requires: (php-composer(webmozart/assert) >= 1.0 with php-composer(webmozart/assert) < 2)
+Requires: (php-composer(phpdocumentor/reflection-common) >= 2.0 with php-composer(phpdocumentor/reflection-common) < 3)
# remirepo:5
%else
-Requires: php-phpdocumentor-reflection-common >= 1.0.0
-Requires: php-phpdocumentor-type-resolver >= 0.4.0
-Requires: php-webmozart-assert >= 1.0
+Requires: php-phpdocumentor-reflection-common2
+Requires: php-phpdocumentor-type-resolver1
+Requires: php-webmozart-assert
%endif
# From phpcompatinfo report for 4.3.2
Requires: php-reflection
-Requires: php-filter
Requires: php-pcre
Requires: php-spl
# Autoloader
@@ -120,13 +119,8 @@ phpab \
cat <<AUTOLOAD | tee -a src/DocBlock/autoload.php
\Fedora\Autoloader\Dependencies::required([
- [
- '%{_datadir}/php/phpDocumentor/Reflection2/autoload-common.php',
- '%{_datadir}/php/phpDocumentor/Reflection/autoload-common.php',
- ], [
- '%{_datadir}/php/phpDocumentor/Reflection2/autoload-type-resolver.php',
- '%{_datadir}/php/phpDocumentor/Reflection/autoload-type-resolver.php',
- ],
+ '%{_datadir}/php/phpDocumentor/Reflection2/autoload-common.php',
+ '%{_datadir}/php/phpDocumentor/Reflection2/autoload-type-resolver.php',
'%{_datadir}/php/Webmozart/Assert/autoload.php',
]);
AUTOLOAD
@@ -149,8 +143,6 @@ phpab \
cat <<BOOTSTRAP | tee -a bootstrap.php
\Fedora\Autoloader\Dependencies::required([
- // only v0.4 at buidtime
- '%{_datadir}/php/phpDocumentor/Reflection/autoload-type-resolver.php',
'%{buildroot}%{_datadir}/php/phpDocumentor/Reflection/DocBlock%{major}/autoload.php',
'%{_datadir}/php/Mockery1/autoload.php',
]);
@@ -158,10 +150,10 @@ BOOTSTRAP
# use auto_prepend_file to ensure build version used first
RETURN_CODE=0
-for PHP_EXEC in php php71 php72 php73 php74; do
+for PHP_EXEC in php php72 php73 php74; do
if which $PHP_EXEC; then
- $PHP_EXEC -d auto_prepend_file=$PWD/bootstrap.php \
- %{_bindir}/phpunit6 \
+ $PHP_EXEC -d zend.exception_ignore_args=0 -d auto_prepend_file=$PWD/bootstrap.php \
+ %{_bindir}/phpunit8 \
--bootstrap bootstrap.php \
--verbose || RETURN_CODE=1
fi
@@ -183,6 +175,15 @@ exit $RETURN_CODE
%changelog
+* Wed Feb 12 2020 Remi Collet <remi@remirepo.net> - 5.0.0-1
+- update to 5.0.0
+- rename to php-phpdocumentor-reflection-docblock5
+- move to /usr/share/php/phpDocumentor/Reflection/DocBlock5
+- raise dependency on PHP 7.2
+- raise dependency on type-resolver 1
+- raise dependency on reflection-common 2
+- switch to phpunit8
+
* Fri Jan 3 2020 Remi Collet <remi@remirepo.net> - 4.3.4-1
- update to 4.3.4