summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-03-23 14:31:00 +0100
committerRemi Collet <remi@remirepo.net>2021-03-23 14:31:00 +0100
commita2785565369d8f6bb61c999cd81b4386c7e3c06f (patch)
tree4be08cc5b651706554d67bdfdfa1f54b32f14dba
parentd467671a489cb2d9b3ac42cb369a6649d403e908 (diff)
fix FTBFS with PHP 8HEADmaster
-rw-r--r--php-phpdocumentor-reflection-docblock4.spec12
1 files changed, 10 insertions, 2 deletions
diff --git a/php-phpdocumentor-reflection-docblock4.spec b/php-phpdocumentor-reflection-docblock4.spec
index c8789bf..2a69cd3 100644
--- a/php-phpdocumentor-reflection-docblock4.spec
+++ b/php-phpdocumentor-reflection-docblock4.spec
@@ -17,7 +17,7 @@
Name: php-phpdocumentor-reflection-docblock%{major}
Version: 4.3.4
-Release: 4%{?dist}
+Release: 5%{?dist}
Summary: DocBlock parser
License: MIT
@@ -28,6 +28,9 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{gh_commit}.tar.gz
Source1: %{name}-get-source.sh
+# Minimal fix for PHP 8
+Patch0: %{name}-php8.patch
+
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
@@ -103,6 +106,7 @@ Autoloader: %{_datadir}/php/phpDocumentor/Reflection/DocBlock%{major}/autoload.p
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
sed 's#vendor/mockery/mockery/library/Mockery#%{_datadir}/php/Mockery1#' phpunit.xml.dist \
> phpunit.xml
@@ -158,10 +162,11 @@ BOOTSTRAP
# use auto_prepend_file to ensure build version used first
RETURN_CODE=0
-for PHP_EXEC in php php71 php72 php73 php74; do
+for PHP_EXEC in php php73 php74 php80; do
if which $PHP_EXEC; then
$PHP_EXEC -d auto_prepend_file=$PWD/bootstrap.php \
%{_bindir}/phpunit7 \
+ --no-coverage \
--bootstrap bootstrap.php \
--verbose || RETURN_CODE=1
fi
@@ -183,6 +188,9 @@ exit $RETURN_CODE
%changelog
+* Tue Mar 23 2021 Remi Collet <remi@remirepo.net> - 4.3.4-5
+- fix FTBFS with PHP 8
+
* Fri Jan 29 2021 Remi Collet <remi@remirepo.net> - 4.3.4-4
- switch to phpunit7 and fix FTBFS