summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-05 08:31:58 +0200
committerRemi Collet <remi@remirepo.net>2017-05-05 08:31:58 +0200
commit49c8569e087e158ce68b63fff93f167b28dd6e99 (patch)
tree963d30c8e4bbdef6c134f8c123ad53dc66fe6143
parentb6e745cd90ce916383882ba89984a2bb87125991 (diff)
backport
-rw-r--r--.gitignore7
-rw-r--r--Makefile4
-rw-r--r--composer.json26
-rw-r--r--php-phpdocumentor-reflection-docblock2.spec7
4 files changed, 42 insertions, 2 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..4dffa22
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,26 @@
+{
+ "name": "phpdocumentor/reflection-docblock",
+ "type": "library",
+ "license": "MIT",
+ "authors": [
+ {"name": "Mike van Riel", "email": "mike.vanriel@naenius.com"}
+ ],
+ "require": {
+ "php": ">=5.3.3"
+ },
+ "autoload": {
+ "psr-0": {"phpDocumentor": ["src/"]}
+ },
+ "require-dev": {
+ "phpunit/phpunit": "~4.0"
+ },
+ "suggest": {
+ "dflydev/markdown": "~1.0",
+ "erusev/parsedown": "~1.0"
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "2.0.x-dev"
+ }
+ }
+}
diff --git a/php-phpdocumentor-reflection-docblock2.spec b/php-phpdocumentor-reflection-docblock2.spec
index ce0be2a..757b29c 100644
--- a/php-phpdocumentor-reflection-docblock2.spec
+++ b/php-phpdocumentor-reflection-docblock2.spec
@@ -1,4 +1,6 @@
-# spec file for php-phpdocumentor-reflection-docblock2
+# remirepo spec file for php-phpdocumentor-reflection-docblock2, from:
+#
+# Fedora spec file for php-phpdocumentor-reflection-docblock2
#
# Copyright (c) 2014-2015 Remi Collet
# 2017 Remi Collet, Shawn Iwinski
@@ -86,7 +88,8 @@ cp -pr src/* %{buildroot}%{_datadir}/php
RETURN_CODE=0
for PHP_EXEC in %{_bindir}/php %{?rhel:php54 php55} php56 php70 php71; do
if [ "%{_bindir}/php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC %{_bindir}/phpunit --verbose \
+ $PHP_EXEC -d auto_prepend_file=%{buildroot}%{_datadir}/php/phpDocumentor/Reflection/DocBlock2/autoload.php \
+ %{_bindir}/phpunit --verbose \
--bootstrap %{buildroot}%{_datadir}/php/phpDocumentor/Reflection/DocBlock2/autoload.php \
|| RETURN_CODE=1
fi