summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-08 13:57:25 +0200
committerRemi Collet <remi@remirepo.net>2017-08-08 13:57:25 +0200
commitcaf45bbfb1ee76fc82e05f7bb0202bf0c924630b (patch)
treea3b37cd88a444cbc9b0a8f902099666c37171169
parentc754c5b3e5c74268e510aa1ff5c0a0d3f34b1a45 (diff)
v3.2.2
-rw-r--r--php-phpdocumentor-reflection-docblock-pr113.patch44
-rw-r--r--php-phpdocumentor-reflection-docblock.spec18
2 files changed, 6 insertions, 56 deletions
diff --git a/php-phpdocumentor-reflection-docblock-pr113.patch b/php-phpdocumentor-reflection-docblock-pr113.patch
deleted file mode 100644
index 50b11f8..0000000
--- a/php-phpdocumentor-reflection-docblock-pr113.patch
+++ /dev/null
@@ -1,44 +0,0 @@
-From 358daaf824d8f6e1acc56eee40127f4bd4153051 Mon Sep 17 00:00:00 2001
-From: Roberto Espinoza <roberto.espinoza@nature.com>
-Date: Mon, 7 Aug 2017 12:56:26 +0900
-Subject: [PATCH] Check tag body has a value before trying to access it as an
- string array
-
----
- src/DocBlock/StandardTagFactory.php | 2 +-
- tests/integration/DocblocksWithAnnotationsTest.php | 3 ++-
- 2 files changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/src/DocBlock/StandardTagFactory.php b/src/DocBlock/StandardTagFactory.php
-index 786caef..8efd84e 100644
---- a/src/DocBlock/StandardTagFactory.php
-+++ b/src/DocBlock/StandardTagFactory.php
-@@ -113,7 +113,7 @@ public function create($tagLine, TypeContext $context = null)
-
- list($tagName, $tagBody) = $this->extractTagParts($tagLine);
-
-- if ($tagBody[0] === '[') {
-+ if ($tagBody !== '' && $tagBody[0] === '[') {
- throw new \InvalidArgumentException(
- 'The tag "' . $tagLine . '" does not seem to be wellformed, please check it for errors'
- );
-diff --git a/tests/integration/DocblocksWithAnnotationsTest.php b/tests/integration/DocblocksWithAnnotationsTest.php
-index 3c40f4f..6db1604 100644
---- a/tests/integration/DocblocksWithAnnotationsTest.php
-+++ b/tests/integration/DocblocksWithAnnotationsTest.php
-@@ -23,6 +23,7 @@ public function testDocblockWithAnnotations()
- /**
- * @var \DateTime[]
- * @Groups({"a", "b"})
-+ * @ORM\Entity
- */
- DOCCOMMENT;
-
-@@ -30,6 +31,6 @@ public function testDocblockWithAnnotations()
- $factory = DocBlockFactory::createInstance();
- $docblock = $factory->create($docComment);
-
-- $this->assertCount(2, $docblock->getTags());
-+ $this->assertCount(3, $docblock->getTags());
- }
- }
diff --git a/php-phpdocumentor-reflection-docblock.spec b/php-phpdocumentor-reflection-docblock.spec
index cdcccc9..779e09d 100644
--- a/php-phpdocumentor-reflection-docblock.spec
+++ b/php-phpdocumentor-reflection-docblock.spec
@@ -8,15 +8,15 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 183824db76118b9dddffc7e522b91fa175f75119
+%global gh_commit 4aada1f93c72c35e22fb1383b47fee43b8f1d157
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpDocumentor
%global gh_project ReflectionDocBlock
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-phpdocumentor-reflection-docblock
-Version: 3.2.1
-Release: 2%{?dist}
+Version: 3.2.2
+Release: 1%{?dist}
Summary: DocBlock parser
Group: Development/Libraries
@@ -28,9 +28,6 @@ URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: %{name}-%{version}-%{gh_commit}.tar.gz
Source1: %{name}-get-source.sh
-# https://github.com/phpDocumentor/ReflectionDocBlock/pull/113
-Patch0: %{name}-pr113.patch
-
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
%if %{with_tests}
@@ -92,7 +89,6 @@ DocBlocks or otherwise retrieve information that is embedded in a DocBlock.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
sed 's#vendor/mockery/mockery/library#%{_datadir}/php#' phpunit.xml.dist \
> phpunit.xml
@@ -136,11 +132,6 @@ cat <<BOOTSTRAP | tee -a bootstrap.php
]);
BOOTSTRAP
-# Notice, with 7.2:
-# 1) phpDocumentor\Reflection\DocBlock\Tags\MethodTest::testCreateMethodParenthesisMissing
-# Uninitialized string offset: 0
-# tests/unit/DocBlock/Tags/MethodTest.php:428
-
# use auto_prepend_file to ensure build version used first
RETURN_CODE=0
for PHP_EXEC in php php56 php70 php71 php72; do
@@ -166,6 +157,9 @@ exit $RETURN_CODE
%changelog
+* Tue Aug 8 2017 Remi Collet <remi@remirepo.net> - 3.2.2-1
+- Update to 3.2.2
+
* Mon Aug 7 2017 Remi Collet <remi@remirepo.net> - 3.2.1-2
- add patch to fix BC break, thanks to Koschei, from
https://github.com/phpDocumentor/ReflectionDocBlock/pull/113