summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorShawn Iwinski <siwinski@redhat.com>2017-07-18 12:13:40 -0400
committerRemi Collet <remi@remirepo.net>2017-08-01 15:48:36 +0200
commit291a6398edd2f43a8ff38529e582baa9d0cab7d2 (patch)
tree714cfcfc233c87051abedce1eb22669827bf8049
parent096a009cb6be9e7757684bda6a77efad188b64db (diff)
Update to 3.2.0 (RHBZ #1471379)
-rwxr-xr-xphp-phpdocumentor-reflection-docblock-get-source.sh69
-rw-r--r--php-phpdocumentor-reflection-docblock.spec23
2 files changed, 84 insertions, 8 deletions
diff --git a/php-phpdocumentor-reflection-docblock-get-source.sh b/php-phpdocumentor-reflection-docblock-get-source.sh
new file mode 100755
index 0000000..5f9241e
--- /dev/null
+++ b/php-phpdocumentor-reflection-docblock-get-source.sh
@@ -0,0 +1,69 @@
+#/bin/sh
+
+GIT=`which git`
+RPM=`which rpm`
+
+if [ -z "$GIT" ]
+then
+ echo "ERROR: 'git' command not found" 1>&2
+ exit 1
+elif [ -z "$RPM" ]
+then
+ echo "ERROR: 'rpm' command not found" 1>&2
+ exit 1
+fi
+
+function print {
+ echo -e "\e[0;33m>>>>> ${1}\e[0m"
+}
+
+if [ -x "$1" ]
+then
+ SPEC=$1
+else
+ SPEC=`ls *.spec | head -1`
+fi
+
+NAME=`echo $SPEC | sed 's#\.spec##'`
+VERSION=`egrep '^Version:' $SPEC | awk '{print $2}'`
+
+print "SPEC = $SPEC"
+print "NAME = $NAME"
+
+GIT_OWNER=`egrep '%global\s*gh_owner' $SPEC | awk '{print $3}'`
+GIT_NAME=`egrep '%global\s*gh_project' $SPEC | awk '{print $3}'`
+GIT_COMMIT=`egrep '%global\s*gh_commit' $SPEC | awk '{print $3}'`
+GIT_REPO=https://github.com/${GIT_OWNER}/${GIT_NAME}
+GIT_DIR=`echo $GIT_REPO | sed 's#.*/##'`
+
+print "GIT_OWNER = $GIT_OWNER"
+print "GIT_NAME = $GIT_NAME"
+print "GIT_COMMIT = $GIT_COMMIT"
+print "GIT_REPO = $GIT_REPO"
+print "GIT_DIR = $GIT_DIR"
+
+TEMP_DIR=$(mktemp --dir)
+
+pushd $TEMP_DIR
+ print "Cloning git repo..."
+ $GIT clone $GIT_REPO
+
+ pushd $GIT_DIR
+ print "Checking out commit..."
+ $GIT checkout $GIT_COMMIT
+ popd
+
+ TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
+ print "TAR_DIR = $TAR_DIR"
+
+ mv $GIT_DIR $TAR_DIR
+
+ TAR_FILE=`$RPM --eval='%{_sourcedir}'`/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+ print "TAR_FILE = $TAR_FILE"
+
+ [ -e $TAR_FILE ] && rm -f $TAR_FILE
+ tar --exclude-vcs -czf $TAR_FILE $TAR_DIR
+ chmod 0644 $TAR_FILE
+popd
+
+rm -rf $TEMP_DIR
diff --git a/php-phpdocumentor-reflection-docblock.spec b/php-phpdocumentor-reflection-docblock.spec
index bb0fd70..d5ececf 100644
--- a/php-phpdocumentor-reflection-docblock.spec
+++ b/php-phpdocumentor-reflection-docblock.spec
@@ -8,21 +8,25 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 8331b5efe816ae05461b7ca1e721c01b46bafb3e
+%global gh_commit 46f7e8bb075036c92695b15a1ddb6971c751e585
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpDocumentor
%global gh_project ReflectionDocBlock
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}
Name: php-phpdocumentor-reflection-docblock
-Version: 3.1.1
+Version: 3.2.0
Release: 1%{?dist}
Summary: DocBlock parser
Group: Development/Libraries
License: MIT
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}.tar.gz
+
+# GitHub export does not include tests.
+# Run php-phpdocumentor-reflection-docblock-get-source.sh to create full source.
+Source0: %{name}-%{version}-%{gh_commit}.tar.gz
+Source1: %{name}-get-source.sh
BuildArch: noarch
BuildRequires: php-fedora-autoloader-devel
@@ -31,7 +35,7 @@ BuildRequires: php(language) >= 5.5
BuildRequires: php-composer(phpdocumentor/reflection-common) < 2
BuildRequires: php-composer(phpdocumentor/reflection-common) >= 1.0
BuildRequires: php-composer(phpdocumentor/type-resolver) < 1.0
-BuildRequires: php-composer(phpdocumentor/type-resolver) >= 0.2.0
+BuildRequires: php-composer(phpdocumentor/type-resolver) >= 0.4.0
BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php-composer(webmozart/assert) < 2
BuildRequires: php-composer(webmozart/assert) >= 1.0
@@ -39,7 +43,7 @@ BuildRequires: php-composer(webmozart/assert) >= 1.0
# "mockery/mockery": "^0.9.4"
BuildRequires: php-composer(mockery/mockery) < 1
BuildRequires: php-composer(mockery/mockery) >= 0.9.4
-# From phpcompatinfo report for 3.1.1
+# From phpcompatinfo report for 3.2.0
BuildRequires: php-filter
BuildRequires: php-pcre
BuildRequires: php-reflection
@@ -55,10 +59,10 @@ Requires: php(language) >= 5.5
Requires: php-composer(phpdocumentor/reflection-common) < 2
Requires: php-composer(phpdocumentor/reflection-common) >= 1.0
Requires: php-composer(phpdocumentor/type-resolver) < 1
-Requires: php-composer(phpdocumentor/type-resolver) >= 0.2.0
+Requires: php-composer(phpdocumentor/type-resolver) >= 0.4.0
Requires: php-composer(webmozart/assert) < 2
Requires: php-composer(webmozart/assert) >= 1.0
-# From phpcompatinfo report for 3.1.1
+# From phpcompatinfo report for 3.2.0
Requires: php-filter
Requires: php-pcre
Requires: php-reflection
@@ -135,7 +139,7 @@ BOOTSTRAP
# use auto_prepend_file to ensure build version used first
RETURN_CODE=0
-for PHP_EXEC in php php56 php70 php71; do
+for PHP_EXEC in php php56 php70 php71 php72; do
if which $PHP_EXEC; then
$PHP_EXEC -d auto_prepend_file=$PWD/bootstrap.php \
%{_bindir}/phpunit --verbose \
@@ -158,6 +162,9 @@ exit $RETURN_CODE
%changelog
+* Tue Jul 18 2017 Shawn Iwinski <shawn@iwin.ski> - 3.2.0-1
+- Update to 3.2.0 (RHBZ #1471379)
+
* Fri May 5 2017 Shawn Iwinski <shawn@iwin.ski>, Remi Collet <remi@remirepo.net> - 3.1.1-1
- update to 3.1.1
- raise dependency on PHP 5.5