summaryrefslogtreecommitdiffstats
path: root/php-phpdocumentor-reflection-common2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phpdocumentor-reflection-common2.spec')
-rw-r--r--php-phpdocumentor-reflection-common2.spec127
1 files changed, 127 insertions, 0 deletions
diff --git a/php-phpdocumentor-reflection-common2.spec b/php-phpdocumentor-reflection-common2.spec
new file mode 100644
index 0000000..4264e4f
--- /dev/null
+++ b/php-phpdocumentor-reflection-common2.spec
@@ -0,0 +1,127 @@
+# remirepo spec file for php-phpdocumentor-reflection-common, from:
+#
+# Fedora spec file for php-phpdocumentor-reflection-common
+#
+# Copyright (c) 2017 Shawn Iwinski <shawn@iwin.ski>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner phpDocumentor
+%global github_name ReflectionCommon
+%global github_version 1.0.1
+%global github_commit 21bdeb5f65d7ebf9f43b1b25d404f87deab5bfb6
+
+%global composer_vendor phpdocumentor
+%global composer_project reflection-common
+
+# "php": ">=5.5"
+%global php_min_ver 5.5
+
+# Build using "--without tests" to disable tests
+%global with_tests 0%{!?_without_tests:1}
+
+%{!?phpdir: %global phpdir %{_datadir}/php}
+
+Name: php-%{composer_vendor}-%{composer_project}
+Version: %{github_version}
+Release: 1%{?github_release}%{?dist}
+Summary: Common reflection classes used by phpdocumentor
+
+Group: Development/Libraries
+License: MIT
+URL: https://github.com/%{github_owner}/%{github_name}
+# GitHub export does not include tests.
+# Run php-phpdocumentor-type-resolver-get-source.sh to create full source.
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
+
+BuildArch: noarch
+# Tests
+%if %{with_tests}
+## composer.json
+BuildRequires: php(language) >= %{php_min_ver}
+BuildRequires: php-composer(phpunit/phpunit)
+## phpcompatinfo (computed from version 1.0)
+BuildRequires: php-pcre
+BuildRequires: php-spl
+## Autoloader
+BuildRequires: php-fedora-autoloader-devel
+%endif
+
+# composer.json
+Requires: php(language) >= %{php_min_ver}
+# phpcompatinfo (computed from version 1.0)
+Requires: php-pcre
+Requires: php-spl
+# Autoloader
+Requires: php-composer(fedora/autoloader)
+
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
+%description
+Common reflection classes used by phpdocumentor to reflect the code structure.
+
+Autoloader: %{phpdir}/phpDocumentor/Reflection/autoload-common.php
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+
+%build
+: Create autoloader
+%{_bindir}/phpab --template fedora --output src/autoload-common.php src
+
+
+%install
+mkdir -p %{buildroot}%{phpdir}/phpDocumentor
+cp -rp src %{buildroot}%{phpdir}/phpDocumentor/Reflection
+
+
+%check
+%if %{with_tests}
+BOOTSTRAP=%{buildroot}%{phpdir}/phpDocumentor/Reflection/autoload-common.php
+
+: Upstream tests
+RETURN_CODE=0
+for PHP_EXEC in php php56 php70 php71 php72; do
+ if which $PHP_EXEC; then
+ $PHP_EXEC -d auto_prepend_file=$BOOTSTRAP \
+ %{_bindir}/phpunit --verbose || RETURN_CODE=1
+ fi
+done
+exit $RETURN_CODE
+%else
+: Tests skipped
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE
+%doc *.md
+%doc composer.json
+%dir %{phpdir}/phpDocumentor
+%dir %{phpdir}/phpDocumentor/Reflection
+ %{phpdir}/phpDocumentor/Reflection/autoload-common.php
+ %{phpdir}/phpDocumentor/Reflection/Element.php
+ %{phpdir}/phpDocumentor/Reflection/File.php
+ %{phpdir}/phpDocumentor/Reflection/Fqsen.php
+ %{phpdir}/phpDocumentor/Reflection/Location.php
+ %{phpdir}/phpDocumentor/Reflection/Project.php
+ %{phpdir}/phpDocumentor/Reflection/ProjectFactory.php
+
+
+%changelog
+* Sat Nov 18 2017 Remi Collet <remi@remirepo.net> - 1.0.1-1
+- Update to 1.0.1
+- ensure current version is used during the test
+- use git snapshot as sources for tests
+
+* Sat Mar 11 2017 Shawn Iwinski <shawn@iwin.ski> - 1.0-1
+- Initial package